WD Elements 4TB external drive does not show up after computer wakes from sleep (Win 8.1)

I have a brand new WD Elements 4TB drive. It works great for the most part.

When my PC goes to sleep, the drive light just blinks slowly. Then when the computer wakes up, the drive is not recognized anywhere in the PC and is not accessable. I can’t even see it show up as a drive letter.

This means that I have to keep my PC on all the time (I use the drive for automatic backups).

In order to get the drive to recognize again, I have to restart the PC. (Power cycling the drive does not work)

I have tried swapping the power supply.

I have tried swapping the cable.

I have tried a different USB plug.

I have disabled “USB Selective Suspend” from the power settings.

I have unchecked “Allow this computer to turn off this device to save power” in all USB Root Hubs in Device Manager.

I have tried re-installing all USB hub drivers.

My OS is up to date. (Windows 8.1)

I have no idea what else to try. I NEED my pc to go to sleep, 

Any ideas? I have tinkered with this for days. I can’t figure it out.


Hello and welcome to the WD community.

Try to go to to device manager and scan for hardware changes to see if this helps the drive come up without restarting the computer.

Nope. Didn’t work. 

My computer woke up, and the drive was not noticed (per usual)

I scanned for hardware changes, and nothing was found. Drive still not there.

Had to restart computer to get the drive to show up again.

Also, I had a Microsoft assistant remote into my PC. He sees nothing wrong from an OS standpoint.

What else can I check?