WD Elements extremely slow - won't respond - won't work


I own 2 WD Elements 1.5 TB and unfortunately one f them has stopped working. Although it is normally recognised by windows 7, I cannot copy anything on the disk.

The pop-up “copying” appears and then, after I wait for several minutes, nothing happens. This also happens when I try to copy small files ~2 MB… After many minutes, the file is still not copied on the disk.

I also tried formatting the disk, however the dialog-box stucks to “Formatting” for several minutes without any progress.

It is as if nothing can be written on the disk.

To mu amazement, HD Sentinel reports the disk as being 100% healthy, however I do not kno if the program attempts to write anything to the HDD before coming to that conclusion.

Any ideas what to do ?

Thankfully the disk is completely empty and haven’t lost any valuable data, however I cannot use it at all.

Thanks a lot for any help.

UPDATE : It appears that the disk DOES work, however it takes about 30 seconds to copy a 1 MB file. It also takes 30 seconds to delete this 1 MB file !

I tried copying a 1.5 GB file and although it started quite fast, about 25% into the progress the speed dropped to silly numbers and it says that 55 minutes are now needed to copy the file.

What is wrong with it ?

It seems ghat you have a bad disk or buggy drivers running on windows

Search on google drivecleanup.zip and run as administrator, reboot the pc and retest :slight_smile:

From what I’ve read so far, it sounds to me that your drive is either having bad sectors or a worn out head (usually comes with clicking sounds).

If i were you, i will not waste anymore time and start to retrieve all the files inside to another HDD.

Well, I checked the disk with the appropriate utility in WIndows 7 (also enabled error checking for bad sectors) and no errors or bad sectors were found !!

So why is the disk performing so bad.

Also run the tool for the drivers as suggested (drivecleanup), but nothing changed…

Ok what is the temperature of the disk while running?

50 degrees Celcius max