WD Elements Desktop issues


I have what I believe is a WD Elements Desktop external hard drive, I think it is 1.5TB but could easily just be 1TB - the ‘Device Name’ is 15EADS External if that helps.

I have had this device for a good few years now and have never had a problem with it until now, when connected to my TV all is good, it plays my media files etc but when I connect it to my laptop it seems unrecognizable and looks like it wants me to format it, the hard drive’s power also randomly cuts out when connected to the TV.

A few years ago I broke the original power cable and have since being using an unofficial one but again it’s worked perfectly fine so not convinced that is the problem, especially considering how it works fine when connected to my TV but I can’t access it when connected to my laptop.

Any ideas or advice would be much appreciated.

Kind regards,


Is the drive power adapter directly connected to the wall outlet? Also did you turn off the tv first before disconnecting the drive?

Thank you for getting back to me.

The adaptor is plugged into an extension lead which it has always been.

I have to be honest and say I dont think I have always turned off the TV before disconnecting the drive.

Hope this paints a clearer picture for you of the problem.



Try connecting it directly to a wall outlet. If your laptop still cannot recognize it and asking you to reformat try a diff comp. If still the same go to any data recovery center for them to help you recover your data.

I have recently formatted the HD as no other solutions resolved the issue, since the format though transferring files from my laptop to the HD are taking ages and i mean ages, something that used to take a couple of minutes - any reason why this might be?