WD Elements 3TB not working

Hello guys,

My 3TB Elements suddenly not working on my Mac. The power is always connected to ups, and the usb cable only connected to PC when needed. Normally the Elements led light turn on (and blinking) only when we plug the USB cable to the computer, but this time it’s always on when I turn on the ups. But when I connect the usb cable to pc nothing is happen. The led is not blinking, the Elements is not showing on Disk Utility either. I’ve tried on every usb port and in my macbook pro with same result. Any thought?

Hello,

Please refer to the following KBA article: Windows or macOS Cannot Find My Drive

Whenever you connect an external drive to your mac, the storage drive may not show up on Desktop, Finder or even on Disk Utility due to various reasons:

  1. USB connectivity problem
  2. MacOS preference settings
  3. Partition map damage
  4. Device incompatibility
  5. Physical damage on a drive

However, to fix the issue, you can try the below methods:

  1. Check the USB connectivity
  2. Enable visibility of external hard drive
  3. Update macOS
  4. Repair external hard drive by using Disk Utility
  5. Repair external hard drive by using Terminal
  6. Erase the external hard drive
  7. If none of the above works, then the drive needs replacement

Further, you can also check the below link for steps to be followed in each method mentioned above:

https://www.stellarinfo.com/blog/recover-external-hard-drive-not-showing-up-on-mac/

Hope it helps!