WD Elements 2TB not detected

After 5 years using this drive, suddenly was not detected by Windows10. I tried four different computers and several USB cables with the same result. Also 2 different power supply.

When connected to the computer the front LED flashes two time and stops, but I can heard the drive spinning. Windows disk administrator requests a disk inisialisation but of course this will delete all the data inside.

WD Drive Utilities software says that S.M.A.R.T is OK, quick test is OK and complete test is also OK ¿? While doing the test the front LED is always turned on but no flashing. Indicated size on the top of the windows is not correct, it shows 3971678,42 TB for a 2TB drive.

Any idea?

Could be the disk was trashed.

Check with Disk Manager and see if it is recognized there.

Windows disk manager requests to initilize the disk, it’s already said in my post, but WD Drive Utility says that is OK that’s why I’m confused.

Can you remove the bare disk and try it in a desktop to see what is up

Eii it works and no data was lost!! When I connected the HDD directly yo the PC motherboard controller there are not read/write problems and HDD is detected by the PC.

Does this means that the controller board of the disc is damaged?. If so, can be purchased as a spare part?

Thanks a lot

A new USB hard disk is not expensive, I suggest 2 or even 3 of them for redundancy

You can give a try to below mentioned 2 different methods to resolve the issue:

Method 1. Use Disk Management to fix not initialized error on external hard drive

  1. Connect uninitialized external hard drive to your PC.
  2. Press Win + R keys, type: diskmgmt.msc and hit Enter.
  3. Find the uninitialized, unknown external hard drive with I/O device error > Right-click on it and select Initialize Disk.
  4. Then set the disk to initialize and set disk as MBR or GPT.

After this, you may reboot your PC and keep all changes. Now, your external hard drive will be recognized and read by Windows again.

Method 2. Run CMD to repair I/O device error on not initialized external hard drive

This CMD command would erase all data on the uninitialized hard drive, which you can later restore after repairing the external hard drive not initialized, with the help of any data recovery or partition recovery software:

  1. Press Win+R > Type: diskpart and hit Enter.
  2. Type: list disk and hit Enter.
  3. Type: select disk F and hit Enter; (replace F with the drive letter of an uninitialized external hard drive).
  4. Type: clean and hit Enter.
  5. Type: convert gpt or convert mbr and hit Enter.
  6. Type: create partition primary and hit Enter.
  7. Type: format quick fs=ntfs and hit Enter.
  8. Type: assign and hit Enter.
  9. Type: exit and hit Enter.

Try the above methods & share the outcome!

Many thanks for your suggestions, Jose2020 but days ago I ordered a new WD controller board. (When I say “WD controller” I refer to the small PCB attached to the HDD and fixed by an screw that fits the power and USB connectors).Yesterday arrived, and today once replaced the problem remains the same. It’s crazy!

Why the HDD alone connected to the PC internal bus works like a charm and not throught the WD controller ? If the electronic board that remains attached to the HDD was defective I also have had an error when the HDD was directly connected to the PC bus, it isn’t?

I tried to do this but fom the Disk Manager, and even from the command line using diskpart, I always get an “I/O error” only if the drive is connected through USB. The drive connected to the PC SATA bus directly always work.

As I tried two different WD controller boards with the same results I suspect that the PCB embedded into the disk is damaged, but then, why only fails when the controller board is connected an used through USB? It’s crazy!

An I/O device error is an indicator of a failing hard drive or USB media. Failure could be logical or mechanical such as file system corruption or stuck actuator arm. Additionally, a faulty wire, disk errors, severe drive corruption, corrupt driver, and hardware damage could also lead to the hard drive device I/O error.

To fix the I/O error, you can try the below methods:

  1. Check if the drive is connected properly
  2. Reset the BIOS
  3. Re-install the drive’s drivers
  4. Try connecting to a different port/PC

Hope this helps!

After a couple of tests I concluded that BOTH WD controllers are damaged (even the new one that I purchased). I checked both controllers with another 1TB WD HDD with the same result on 3 different PCs.

Later I used a cheap SATA to USB controller found in a cupboard corner and BOTH disks worked well so, it seems to be impossible but BOTH WD controllers are damaged.

The curios thing is that in all the cases if I use the WD Dashboard (disk utility software) ,iwt shows that the disk status is correct and there are no problems ¿?