WD Elements 2TB External hard drive BLINKING LIGHT Problem


#1

Here is my shot in the dark. 

My WD Elements 2TB External hard drive is not working.  My MacBook Pro won’t recognize the device.  The tiny bulb is constantly blinking when plugged in.  Showing there is power, just not reading.

I’ve tested and swapped the USB cable and Power output, checked on a different computer and looked at Disk Utility, ALL with no luck.

I’ve had this external hard drive for less then a year and am still under warranty.  I’m looking to avoid a Data Recovery .  It’s expensive and not a flawless process. 

Anyone have a solution?

-Thank you


#2

If the drive is not on disk utility and you’ve checked other computers and cables then there’s not much to do other than data recovery or a replacement.


#3

It could be the power supply although its showing its getting power but it could be lower than needed to

function correctly had this happen on another brand last year plugged in another power supply that met the specs with the right polarity plug and all was well.


#4

hi… i just got my external hard drive and everything connects e.g my usb cord and my ac adaptor … but when this is all pluged in my light blinks and thats all that happends … i have tried some stuff such as … trouble shooting and the disk manager steps but none of this works… on the disk manager my external hard drive does not show up even though its pluged in … im really cconfused… could anyone help… btw im using windows 7 and its compatible with it !!! if you have solved this question could you reply … help me !!!

thanks …


#5

Hi

I m having exactly the same issue…but Im connecting the WD 2TB to my dell inspirion Laptop , OS : Win 7

Tried all the following :

  1. Different USB cables.

  2. Different Power adapters.

  3. Well tried connecting the WIndow server 2003

  4. No sound that the device is detected, no sound in the hard disk either

  5. Cant see in the disk management

.the 2TB is just  5months old and I have recently moved all my documents,movies,pics,music into the 2 TB…so please help  ( P/N number :WDBAAU0020HBK-01)


#6

After less than a year with my 2 TB WD external drive with the same P/N number, I too get a blinkiing LED light and my Windows 7 is unable to recognize the disk. There seems to be some spinning of the HD when it is plugged in, but then it slows down to silence… Now only the LED is blinking. Unacceptable :(  It was working for a few months without a problem :(. Any suggestions or have we screwed? What does the rapidly blinking LED light mean?


#7

Did you try moving the power supply to a different plug not in a surge protector? It might be the voltage adapter. If it’s still in warranty try calling WD and see if they will send a replacement.

Joe


#8

Hi from a WD newbie.

I have a 3TB model with the blinking light syndrome too!

Under diskmgmt it says that the disk must be reinitialized !

I dont really care about the drive but I need the data on it.

Is there any way to service this drive (service manual?)

or do I need a hacksaw to get at it?

thanks,

:slight_smile:


#9

Sorry for replying to my own email, I forgot to click “Email me when someone responds”.

Actually I put my ear to the disk and it spins up to full speed, stays there for5 seconds then shuts down.

any ideas?

thanks


#10

Hi there, I’m having the same problem with a 1tb drive, computer won’t regognise it, light blinks, and i can hear it spin up when it first powers up.

Has anybody had any solutions as yet?


#11

My 3TB disk was as dead as a doornail :frowning: So, I opened it up with a credit card. 1. plugged the disk in an external docking station to see if I could recup some data. however nothing happened so my disk was definitely dead. 2. powered up the little power supply board and plugged in a 120 GB disk. it was wiped out. So in my case, both the disk and electronics were kaput! my data was lost, but the dealer replaced the disk. Better luck to you!


#12

I accidentaly dropped the disk, the light is blinking, the device is recognised in bios mode and in device management but i cant see it on my computer. I tried some programs to save my data but they show my disk with wrong capacity (2T instead of 1.5T) and they show the disk is empty. Also in disk management the disk appears as unknown and not registered or allocated , there is no drive letter . Is there any way to retrieve my data? It’s realy important! Thank you in advance.


#13

HALLO…What happened with you happened with me the same seinario…am checking the solution in the forums…we can cooperate to find a solutoin…deal…:slight_smile:


#14

Hi I’m having the exact same problem. Flashing light for 1 minute with spinning sound and then it shuts down. I have only had the hard drive for a week but threw out the box, hopefully that isnt a problem! I googled the solution but there is none. Do any WD employees or technicians actually read this forum?


#15

Everyone has been commenting on what do for fixing drive showing (lights on) but not showing in “My Comoputer” and also under Disk management.

Check and see if the drive is formatted or been used under a different OS (linux,MAC, ect).

Once I removed it from disk management I was then able to format the drive.

The drive then shows up under My Computer !!!

VIOLA…


#16

I’ve had my 2TB for only a month or so.  Was working fine.  I just plugged it in again after changing locations (upstairs/downstairs) and the light blink only once or twice - then stops.  The HD does not spin.  It’s like it is simply dead.

Tried changing the power cable with another 2TB I have but that didn’t work either.

I’m ticked.  Back to Best Buy tomorrow.


#17

Hello

I m having exactly the same issue…but Im connecting the WD 2TB to my Asus U series Laptop , OS : Win 7

Tried all the following :

  1. Different USB cables.

  2. Different Power adapters.

  3. Different laptops.

but i’m getting low light blinking and can’t see on WD Smartware when i click the power button on the back

the blinking light become strong but thats it …it won’t work

please give me a solution

my P/N : WDBAAH0020HCH-00

thanks…


#18

Hey folks, an update on my case…

I had the bloke at the local computer shop open it up and take a look…says it’s cactus, time for data recovery. I goes without saying it’s the last time I buy a WD drive of any type. A terminal fault in a drive about a year old is unacceptable.


#19

Posted in another thread but this fixed my problem with computer not detecting WD drive:

Just bought a new 2 TB WD Element and found it didnt plug and play like other external drive. Read someone’s suggestion about it may not have enough power so plugged the power into a DEDICATED power socket and it works (Required you to format it again via windows). Most people would have a multi socket adaptor for their PC, Monitor, etc which is why this problem is so often.

I have Windows 7 Operation System. Hope this helps anyone whom bought it. Wierd, after i formatted, i replugged it into the one I had with multi adaptor socket and it works fine now!


#20

Same for me. Bought a new one arrived today and although two laptops recognized it had been connected and drivers were installed, the drive was not visible in explorer. Plugging directly into a wall plug resolved the problem. Note though it does seem where the ac plugs into the drive it mates very poorly so even moving the drive slightly causes a power reduction resulting in explorer losing the drive. This might explain why others have had this problem after moving the unit. Seem like a basic design faults to me.