[Possible cause] Blinking Light with WD Elements - no showing or mounting

I own 3 WD Elements external drives, two 1 TB disks and one 2 TB disk.

Since a couple of days I had been experiencing trouble with the 2 TB version.

At random it suddenly dissapeared from the desktop and could not be seen or mounted anymore. A blinking light was the only sign of life left then.

Only thing that worked was to unplug it and plug it in again, after which the isssue repeated itself. Very frustrating. :cry:

So I tried re-formatting multiple times and used several disk utilities to check and repair it but there were no problems found and the problem stayed just the same. :angry:

[Possible cause and solution]

Finally I found what was causing the issue in my case: the external USB hub* - this appears to give too little power for the 2 TB disk.

The 1 TB disks are fine but the 2 TB one becomes unreliable, it does mount and functions at first but later on it ‘just gives up’ because of this. I then was left with a blinking light and that was it.

When I plug it directly into my computer, so without the external USB hub in between, it works without problems (again).

* NOTE: I used a - self-powered - external USB hub (bought this expensive one just to avoid issues like this) but this seems to not be sufficient in the end. :confounded:

After reading these forums I found a post that led to my discovery so I wanted to share back what I have found. :smiley:

My two cents, hopefully this leads to solving problems for others too.

1 Like

Hello Webber, welcome to the WD Community. Thanks for sharing, I’ve seen several examples of this. 

1 Like

Hubs powered or not are a known problem. Another problem is plugging the powersupply into a surge protector instead o of directly into an outlet. These drives are very sensitive to voltage and both can cause problems with some drives. 


1 Like