WD Drive Utilities - 90% and hung?

Okay I have a WD MyBook Duo configured in a mirror, with 2 6TB drives. Seems like daily the drive would flake out and not allow me access to some sub directories declaring a fatal error. During these episodes the drive WD Drive Utilities can’t even see the drive.

After the last episode (and a power restart of the array) I decided to run some of the scans and see if there’s a problem. “Run Drive Status Check” comes back quickly and clean. “Run Quick Drive Test” comes back quickly and clean. “Complete Drive Test” has been stuck at 90% for at least the past 3 hours (as long as I’ve been awake) and was started last night about 11 hours ago.

Does anyone have any experience with how long this should take?

I’m running Windows 10 on a three year old Core i7 connected through USB3 and OS is kept current and updated my systems bios yesterday.

So it wasn’t hung, the scan finally completed.

I’m still not sure why the drive / file system messes up occasionally.

Hi there,

do you have the drive turned on most of the time? Also i would like to know if this happens when you do certain things on the computer or just out of the blue.

The drive is on all the time (unless the system itself is turned off) and I’ve disabled the sleep feature (using the WD Drive Utilities).

As for when it happens it seems almost random, I’m not doing anything in particular.

So now the scan is done, and I’ve been away from my computer for a while, and I can access some files while others files are inaccessible. As an example I can get to directories that in the past caused me trouble but if I dig down into one of my folders containing photos (jpeg format), I can see the files exist but can’t open them. Another symptom is that WD Drive Utilities, sees the drive, but reports it as “0 bytes” and can’t get the raid status.

There really doesn’t seem much rhyme or reason, except periods of inactivity. I’m going to dig through the device manager and see if there’s any power settings in there (maybe the OS is trying to make the drive sleep).

And have you tried a different USB port on the unit to see if this helps? Also can try a different USB cable.

Not yet :smile: I’m still stepping through the trouble shooting steps. I posted here hoping someone else had a similar problem and could point to a quick solution.

Just changed two more settings at the OS level.

  1. “Turn off hard disk after” set it to never
  2. “USB Selective suspend setting” disabled

I’ll try again in a few hours and see if the files / file system is still accessible.

If that doesn’t work, I’ll look at that USB cable and port (as suggested by ArMak).

So it looks like this fixed my problem. If I had to guess it’s the “Turn off hard disk after” setting.

Maybe the guys writing the code for WD Drive Utilities could update the application to present something on the screen that tells the user that the app is still progressing. Testing a new My Book Duo with 2x8GB drives and the application has looked static for about 6 hours now (showing 90%). I will be patient… The WD Diags application, though not as user friendly (in some ways) indicates action with counting the sectors. Not sure if the WD Drive Utilities and actual computer are involved with the drive test enough to see progression that well. If so, maybe a more granular progress bar in 0.01% or 0.001% increments (rather than 10% increments) so we can see the progress better (especially on these ultra large drives).

1 Like

How long it took to complete?