WD Discovery eventually causes high CPU usage

#1

If I run WD Discovery, eventually my CPU usage starts going up and up, to as high as 100%. If I quit WD Discovery, CPU usage goes back to normal. This happens eventually, sometimes sooner, sometimes later. Whether I have a portable hard drive plugged in or not makes little difference.

WD Drive Service/WD Drive Manager uses most of this CPU when this happens.

I have an i5 PC with Windows 10 64 bit, fully up to date.

#2

What WD device is this happening with??

#3

The software in question is WD Discovery v.3.2.256 and My Cloud Desktop v.2.1.0.21S. The problem happens even when the WD portable drive isn’t plugged in.

#4

OK at least we know the device is a My Cloud . There are many My Cloud models, so tell us which model you have.

Better yet:

#5

What WD Portable Drive? My Book? My Passport? What capacity?
Do you have a My Cloud Home? are you using Desktop Sync to the My Cloud Home?

#6

No it’s not a My Cloud.

#7

I think that support for the M.C.D. has been discontinued?

https://wdc.custhelp.com/app/answers/detail/a_id/26337/~/my-cloud-desktop-app-no-longer-works-with-a-my-cloud—login-not-authorized

I just tried it on my WD NAS and the WD My Cloud desktop app just will not see it or even authenticate using the activation code the NAS generates.

Can you try investigate from Task Manager or SysInternals Process Explorer what within WD Discovery is causing the high CPU usage? I’ve got WD Discovery (Not the Windows 10 store app!) running on my computer and not experienced high CPU usage.

I am wondering if I actually need WD Discovery installed? I only really need the WD Security and WD drive utilities for the external USB drive I’ve got.

#8

I’m having a similar issue as OP with a My Cloud Home on Windows 10. The device isn’t currently using as much CPU as it was a few days ago, but I had noticed some spikes and constant noises coming from the device. I have since disabled “Sync to MCH” on the few folders I had set up for sync.

Is it normal to have multiple instances of the processes associated with WD Discovery? I also have “kdd.exe” and “kdd” (without the extension) processes running. I don’t remember seeing all of these extra processes before.

Also, My Cloud Desktop still appears in WD Discovery under Settings > More. Mine is currently showing an available update, but the update never completes.
image