WD Blue (WD10EZEX) Not Showing in Disk Management, please help!

I have a brand new WD Blue internal hard drive (WD10EZEX) that when i connect to my computer, it doesn’t show up in the Disk Management tool. The BIOS recognizes it and the Device Manager recognizes it without any errors.

I tried to change SATA ports and power cables, and tried uninstalling it from the Device Manager. I’ve even tried it in another computer and it has the same issue.

I’m wondering if there is any hot fix or technique I need to use to force Windows to allow me to use it.

I’m running Windows 10 Home and my motherboard is the ASUS B250A-M.

1 Like

Hi: krackd

at https://support.wdc.com/cat_products.aspx?ID=6&lang=en&i
Select your hard drive and download Data Lifeguard Diagnostic for DOS (current version 5.27)

Follow the instructions to create a bootable USB.


Turn off you computer and remove the sata power connector from all the hard drives.
Connect the hard drive that you think may be defective or want to test.
Turn on the computer.
Set your bios to boot from a USB device.
Type dosdlg.exe

Select WRITE ZEROS TO DRIVE and do a full erase.

It should take about 2 to 2.5 hrs per terabyte depending on the computer.

It not only erases the hard drive but it also checks to see if it is working properly.

if the drive is defective it will come back with an error code that WD support wants for a RMA.

NotaCanada

NotaCanada,

Thanks so much! That worked!!

your welcome

NotaCanada

I was having the same problem, this fix worked for me too and I hope it works for anyone who accidentally deletes their partition!