Wd_black d10 not recognised on ps4

Bought the product WD BLACK D10 8TB for the PS4 3 days ago transferred one game over and worked fine , today 9th the PS4 is telling me the USB storage device is not connected or not supported … please advise

try a different USB Port on the PS4 ?

Are you using the PS4 rest mode ? … if so, do a complete power down and reboot.

apologies if you already know this (just mentioning it “in case”) … a PS4 Extended Storage HDD (with game installs) must be plugged directly into the PS4 console. i.e. The HDD won’t work connected through a USB Hub connected to the PS4.

Hi Joey,

I have tried another port, also tried another PS4 , then i tried on the computer expecting to see an notification new usb device connected !!! but nothing in the disk management , What i also noticed was a clicking noise from the unit as if it was trying to boot itself on , the power indicator was blinking (not solid) with that I spoke with the retailer (Curry’s/PC World) where i bought it from and through their live chat the conclusion was to have it replaced… which i have just come back from so fingers cross no repeat

Whats your thoughts ?


Steve Goddard

Take them up on their offer, clicking sounds are not good.

Hard drives formatted as Extended Storage on a PS4 won’t appear anywhere (or any notifications) on a PC because the Format/Partition table is a Sony propriety format.

But … it should be recognized in Disk Management where you reformat/re-partition the drive back to PC format.

If it isn’t displaying in Disk Management then that’s another sign something is wrong with the drive.