WD Backup suddenly stopped working

I’ve had WD Backup installed on since end of Nov '15 and was using it to auto backup (hourly) to a new My Passport external drive. It was working just fine until a couple weeks ago. I noticed a couple days ago that the last backup date was a couple weeks prior.

The drive itself is working fine as I can copy files to it, etc. and it works. (Connected to Windows 10 PC.)

I clicked on Backup Now and nothing happened. I tried to open Settings but nothing happened. I quit the program and opened it again and tried those things again, and still nothing happened.

So I tried to Repair the installation (thru Windows Programs and Features) and got the same result. So I uninstalled the program and reinstalled. Updated it with the available update. And still the same results. It simply seems to be totally unresponsive.

I’m totally frustrated here and don’t know what else to do. Any ideas?



Go to Windows Programs and Features and remove everything related to the WD backup and then reinstall it.
If this does not work then contact WD support for assistance.

OK, thanks

Hi Nathan

I also have this problem same as you.
untill now I still cannot to solve.
Did you solved the problem?