WD backup for Passport Ultra stopped working

I have a WD My Passport Ultra that is less than a year old. It was set up to do automatic back ups. Then suddenly it stopped backing up. When I click on the icon, I get a error message “WD Backup has stopped working”. “Check online for a solution and close the program” does nothing. the window closes and nothing is returned.

I’ve uninstalled all the software and reinstalled all software with the latest. Still no luck.

any ideas on how to fix this?



Hello, do you have another computer that you can test it? You can also alternatively use the WD Smartware to backup your computer.

I am experiencing the same issue. I have also re-installed the software still received “WD Backup has stopped working. A problem caused the program to stop working correctly. Please close the program.” I ran the passport ultra on another laptop and the drive did back it up without issue.

I updated the software, performed the “Complete drive test” & ran “drive status check”. All passed. And, I can access the files when opening the My Passport folder. It appears the drive is functional but when I go to back-up, I receive the same “not working” error. Any ideas?

Hi Christine, I contacted WD support today. They shared thye following and I can now back-up. Hope it helps. "Please follow this steps: Uninstall
WD Smartware > Restart your computer > download latest version
from our website > install WD Smartware > Do not update when
prompt to update. To download the latest version from our website please click on the following link and select the “Download” tab: http://support.wdc.com/product.aspx?ID=223&lang=en
It is important that once you install the latest version if prompt you to
update the software; you do not need to update it because this is
already the latest version. If you ever need to update the WD Smartware software, I do recommend you to download the latest version from our website a install after you uninstall the old version. Sometimes
happens depending on the Operated System that you are working, that
when you hit update software, it does install the software twice and the
installation fails when you run it. That is why I recommend you to do
not update automatically.

Hi Tom,Thank you so much for sharing this. Really apprecaite it and glad to hear you got it to work.


-----Original Message-----

I had the exact same problem. I followed the above directions, and WD Backup installed just fine. However, when going to startit, it says it has stopped working. Is there anything else to try?

I’m having similar problem. It was working fine and all the sudden it stopped. I double clicked on the icon and nothing happened. It sounds like it started something but the program does not open up. I also tried updating and removing/re-installing but same thing happens. I also try “Back Up Now” from the tray but that also does nothing. Anyone has any solution for this? Where is WD support?