WD Back up will not open 2018


#1

I can no longer get WD back up to open on my laptop I click on it a little loading spinner starts but blips out . It will not open.
Tried- run as admin, uninstalled and installed the latest version. Uninstalled all WD software , rebooted , tried again to load only WD Back up. During set up it seemed like it was going to work in set up asking to set up the backup schedule. I let it keep the existing schedule.

Yet is seemed not to do anything . I tried opening the shortcut and it still will not open , even as admin.

The drive is seen on my computer and I can access it.

I also have half of this drive to back up on a PC. The software will open and back up on the PC.

SO what is blocking it on the laptop from opening the software? I really want to back up my laptop.


#2

Hi mghia,

You may refer to the below KBA:

It also may be due to the antivirus and firewall blocking.


#3

Thank you.

Still no luck

  1. I don’t have any issue installing or uninstalling the program. So I am not sure the first suggestion applies as it asks if I am having issues installing or uninstalling and which program.It seems to load just not operate properly.
  2. Ran the DISM tool - and sfc program wont open
  3. I use Windows Defender. I added the WD app manager to the Windows defender firewall.

I dont know what to look for to know if Windows 10 is blocking it or how to shut it off it is.

Program still wont open after loading. That is to say I put the WD back up on my system and it seems to install but will no longer open.


#4

Still cant open What next? How do you find out what is blocking it from opening?


#5

I have uninstalled and reinstalled it (5.10.127) and it won’t open, installed a newer version (8.92.67 and 8.70.315) and the wheel wasn’t found (Driving Force GT), installed a 32-bit version of 5.10.127 and couldn’t even find a .exe file to open it so what else am I supposed to do? Please help.
Lucky Patcher Kodi


#6

Hello, have you found a solution?
I also have the same problem, I uninstall and reinstall but still nothing, it does not open.


Mini Militia App Lock 7Zip


#7

I have the same problem …simply stopped working in October … the WD MY Passport Ultra runs continuously while plugged in, but it does not back up anything and I cannot get the WD backup to launch … no error message, it appears to try to start and then gives up; I added microsoft office to my PC … other than that there is not changes.

Any further suggestions?


#8

Has anybody found a solution.


#9

I can’t exactly remember how I solved it other than I just remove the software put it back and just made a new backup. I’m assuming it had something to do with the software having trouble with the existing backup but I don’t know for sure.
Been working ever since. If I recall I also wiped the WD backup files so there would not be any conflict or waste of space.


#10

I have the same problem. Uninstalled and reinstalled. I set up the backup, but then WD Backup closed and I cannot get it to reopen to confirm anything. Cannot tell if back up is working. Spent hours researching this issue and have not found anything that works. Thanks Western Digital for wasting my time with software that does not work. I’m going to have to try a different backup utility.


#11

Well it DOES work. I just used it. Something is blocking it. DId you just start over including your back up? It seemed making the new back up was the key for me if I recall.


#12

I did start over. Uninstalled and reinstalled WD Backup. I used WD Utilities to erase the previous backup. It looks like it is working. If I look in the tray at the bottom right I can see WD icon and I can click on it and see that it is working. Also in Task Manager - WD Backup is working. But I cannot get the WD BackUp interface (where you can choose backup frequency, folders to back up, etc.) to open up. Tried clicking on WD Settings (from tray area) - nothing happens. Tried Opening up from the Shortcut on desktop - nothing happens. Tried opening up from Windows Program List - nothing happens. Nothing seems to work.


#13

I can not recall what I did back then Sorry. But I recall manually deleting the folders before installing the software. I might have used the software that came with the drive . WD back up is in my icon tray and I can open it and set a schedule.


#14

I think remnants from previous backups were messing things up - thanks mghia for the hint. I uninstalled WD Backup, WD Utilities and WD Security. There were still traces of these programs on my C drive so I manually searched for and deleted everything to do with Western Digital, WD, etc. Downloaded and reinstalled latest software. Seems to work now.


#15

WD Backup has worked fine for a number of years, today when I tried to open the program I got the error message “WD Backup has stopped working”. Here are the details of the problem from the error screen:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: WDBackupSettings.exe
Problem Signature 02: 1.0.5953.19621
Problem Signature 03: 57167eca
Problem Signature 04: System.Runtime.Serialization
Problem Signature 05: 4.7.3260.0
Problem Signature 06: 5bb7c313
Problem Signature 07: 11a8
Problem Signature 08: 2a
Problem Signature 09: System.Xml.XmlException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I also tried accessing the program from the task bar. It opened, but when I selected Backup Now, nothing happened. I am running Windows 7 pro 64-bit SP-1. I have made no changes to my system since the last back-up. And No, I have not dropped the drive. My PC recognizes my MyPassport Ultra and I can open it, but I do not know what to do once I get in there. It appears from the different threads I have found on this site that this is an ongoing problem that is not being addressed.

So, now what.


#16

I’m having the same problem. My WD Backup suddenly stopped working. It doesn’t open up. I tried: 1) unstalling/re-installing; 2) the proverbial “Reboot”; 3) turning off the anti-virus software; 4) adding WD Backup to the “allowed apps” in WIndows So-Called Defender.

Nothing has worked. Good luck, Western Digital. It has been nice knowing you!


#17

Has your system crashed? If not just delete the back up and start fresh Seemed to work for me and has not failed to back up since.


#18

I believe “WD backup” should open regardless of whether the external drive is even attached or not (which would leave me to believe that deleting a backup off the drive wouldn’t make any difference).


#19

You have a choice, try another suggestion or do nothing. Just deleting software, which you assume should work, did not fix it for me. But starting as if the system and drive was new did seem to work.
We might have two different issues. I can only tell you what I tried what failed and what appeared to work me.

Good luck with whatever you try (or don’t try_


#20

Thank you. To be honest, I’m just going to copy things manually. If you step back and think about it, it’s quite breathtaking – WD has trouble creating a software program that SIMPLY OPENS on Windows 10, an ubiquitous operating system. It tells you all you need to know about them, doesn’t it?