WD Backup won't open!

Hello,

I’ve having issues with the WD Backup App lately as I cannot backup my computer or open the app itself.

I’ve updated it to the latest version, uninstalling it and reinstalling it and it still doesn’t work.

I don’t know what to do!

Any suggestions?

Thank You

1 Like

Hello,

Please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/12279/

I reinstalled the software and WD Backup still doesn’t open!

Hi, did you find a solution for this problem?
I tried to update WD Backup then after that, the software seems not to be installed correctly and don’t open anymore.
I tried reinstalling it with either the zip file or WD Discovery. I’m frustrated since I need to restore some file from my WD Passport

Nope, I have not found a solution to the issue of WD Backup not opening. It’s frustrating!!!

OK, so I reinstalled WD Discovery, WD Drive Utilities, and WD Backup.
I created a new backup and it finally worked.
I also closed it and reopen it with success!!!
FINALLY!!! LOL

Lucky you! I have reinstalled multiple times WD Discovery & WD Backup and none is working…
Hope they will release an update and resolve this problem soon