WD Backup won't launch (Windows 10)

I’ve been using WD Backup for a couple years now on my PC; including with Windows 10. I tried today to perform a backup via the taskbar, right click WD Backup, “Backup Now”, but nothing happens. I tried going to settings, but the window would not appear (I did notice the loading circle everytime I would try to load it).

I’ve tried updating to the new WD Backup, reinstalling it, making sure I was running in Admin mode, disabling my virus software, and even getting the updated WD Drive Utilities, but to no avail.

Any suggestions?

Thanks!

Hi Xgamer125,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support;

The link below will allow you to call support.

I am a user of windows 10 and I am using the WD backup for a long time. but from the last week I tried a alot to perform backup on my PC but I am unable to do that.I have also checked Microsoft Support Canada to know about this.I have performed all the guidelines and also tried to contact with your technical department.So may I know any solution of this problem??

I’m having the same problem. I’ve been running WD Backup for > a year without issue, doing monthly backups. But today the app won’t launch – spins briefly and then nothing happens. I tried uninstalling, rebooting, then reinstalling – same thing.

Next, I downloaded a newer version of WD Backup and installed it. It allowed this, knowing it was a new version. But it still won’t run. Trying to initiate a backup from the installer says the drive is already assigned to a backup and to use a different tab. But there’s no tab because the app won’t run.

This broke within the last month. WD, what’s going on? How do I get it to run?

hello, I also have the same problem on my pc, the application does not launch, I also reinstalling the application but nothing changes


Mini Militia App Lock 7Zip

i have same troubles. i wrote to tech support this " I UNINstalled and installed again on my thinkpad. i go to the wdbackup.exe and nothing happens. if i go to WDDiscovery.exe a message comes up “No Connected devices”;. i installed wd drive utilities and it starts. this drive works because i backed up my desktop windows XP today. And it performed well on same laptop in May 2018, i have those files backed up. but it will not restart now for some reason. pls help"
lets see how they answer. i am using windows 8.1, has anybody updated their drive’s firmware? results?

I am having the same issue as of a month ago. Last back up was Aug 2019. I installed the new WD Discovery suite, and updated all of the WD Apps (Backup, Utlilties, Security). Backup won’t run. Utilities works. Security doesn’t let me do anything, I can try to remove password, doesn’t work.

What’s going on with this software?

I’m on Win10