WD 1TB Portable Not recognizable after Windows exFAT Format

I am fairly new to External Drives and decided to pick this product up after realizing it had a security feature through the WD website a “WD ELEMENTS USB 3.0 portable hard drive 1TB” SKU:WDBUZ. For certain devices the drive was not recognizable so I decided to format through the default windows feature from NTFS to exFAT and with my lack of knowledge with these things I may have unknowingly might have erased the features to make this drive recognizable to the WD Security application and Drive utilities.

I also seem to have a manifest.json file.

WD Discovery recognizes the drive as “WD Elements” but when I open WD Security it says “Attach a supported WD Drive”. I’ve looked up other solutions such as mine telling me to go to services and change WD Drive Manager startup type to “Automatic” which it already was and it is still not recognizable through WD Security. I just want the ability to setup a password but I am unsure how I’m able to do so now. If anyone could please provide a solution it would be most grateful.

WD Elements drives do not have any security features … i dunno where you read that they do ?

Certainly not from the WD product page … https://shop.westerndigital.com/products/portable-drives/wd-elements-portable-usb-3-0-hdd#WDBUZG0010BBK-WESN

And also in the list of WD Security Unsupported Drives … https://support-en.wd.com/app/answers/detail/a_id/2158

I own several WD Elements drives from 1TB, 2TB & 4TB … and the reason they are cheaper than the WD Passports and WD Passport Ultras… is because they are a basic storage drives with no extra features such as password protection or hardware encryption.