w2go web access issue

Hi there,

I can’t access my two devices from the web anymore. Even though I login properly to the website and the device, I access to a blank Share page (ironically, it says “Shares (5)”) but nothing is showing.

I’m using the last firmware available and installed the last version of Flash. I also tried Firefox and Safari to get the same result.

I’ve tried on a iMac and MacBook both running OS-X Lion 10.7.5.

Any help would be appreciated as t is very frustrating not to be able to access to my drives!


Be sure to have the latest java version installed. If the problem continues, try to access the WD2go website from another PC to see if the same problem happens again.


1 Like

I’m using Java 7 update 17 (latest version available).

I tried on a MacBook Air and got the same issue.

Ain’t got a PC around to check…

Thanks for helping though.

I finally found the issue: my web browsers (as I tried both Safari and Firefox) were running in 32 bits mode while Java 7 runs in 64 bits only.

In case some of you experience the same issue, close your browser and then go into your application folder, right click on the browser icon and select “get info”. In the dialog box that follows, unmark the 32 bit mode nad that’s it.

My 32 bit is checked off and I am still having problems with a message that says “plugin missing”.  I have sent case to wd on Sunday and still no response as of today.

I finally stumbled into the website and found that you have to download the Java version that WD has to correct this issue.  It runs a program that apparently overrides the normal java to load in the “shares” for you to read.  It works fine now.  I assume this is to protect against the issues that Java is having.

I have same issue but on iPad and iPhone on the app. Doesn’t see the device outside of the network on wifi at home. Device is in office dif broadband. Trying to connect with wd2go I just get error 404 message. Now the device is not even listed on wd2go and app won’t find the device.