I’m having trouble connecting through wd2go.com.  I’ve registered my 2tb My book and it shows up when I log in at wd2go.com but when I select view shares my browser (ie) just times out and doesn’t show anything.

I’m using DHCP in my router and tried prot forwarding without using a static ip address.  I’ve not tried a static ip yet and I’ve not used another browser.

Can anyone help?


What is the connection status reported by the MBL?

My guess is connected (I’m at work)  When I try WD2go.com at home (on my wireless router that the HDD is connected to) it shows my shares just fine.

Here is the status of my remote access. 

Again when I’m on my WiFi at home I can connect through wd2go.com.  I’m not sure if the internet connection at work is causing this problem.  I’m going to get my brother to try it when he gets home and I’ll report back.

I have exactly the same problem.

Thanks for any help!

P.S. Could it be a proxy or a firewall at work, that makes problems???

I’ve been super busy so I’ve not had a chance to get my brother to try.  He is going to try tonight to see if it is just my work connection that is causing a problem.  I’ll hopfully have an answer later tonight.

Could it be a possibility, that Java has to be up to date?

It worked now once on my PC, but I have set up a folder for my collegue and he has the same problem, when clicking on the device picture. “Page can’t be loaded…” or whatever ;o(

No, he was not able to connect.  This is really getting frustrating.  I cannot connect to my drive unless I’m at home.  WD2go.com doesn’t work at this time and my mobile app on my tablet won’t connect unless I’m at home either.  Please, someone help.  I’ve read the manual and tried everything it says and still nothing.  I’ve been messing with computer since the late '80’s so I know my way around.  I’ve always liked WD products but this one is starting to doubt my perception.

I’ll try updating my java but I don’t think that’s the problem.  It’s got to be either the drive or my router.

Still the same problem with my access.

Neither mobile is working (can’t be connected - Error 504) and when opening the drive via web on wd2go.com, the browser crashes.

Same with my brothers, who I made a login for.

There appears to be a bug with UPnP within some routers that doesnt allow the MBL to create a UPnP entry for itself. Even though on the MBL GUI, it says “Port forwarding connection established”, it might be showing this in error. 

If your router has UPnP enabled, then disable it and within the MBL GUI select “Manual” connection method and then manually forward the two ports (80 & 443) to the IP Address assigned to your MBL. Always ensure your MBL has a static IP Address (either by assigning it via its MAC address in your Router, or select “Static IP” from within the MBL GUI). 

I had the same issue a while ago, and it took me a while to find the cause and resolve it. You have to be sure you forward the ports within the router after disabling UPnP otherwise the MBL will resort to a relay connection (via WD’s servers).

This issue isnt very well documented, but WD did admit to this problem a little while ago. It is admitted in this post:



1 Like

OK, thanks

Just received a new router from my provider today and will be able to check, once my wife will give me some minutes to disconnect the internet ;o)

Do you have any idea, what I am doing wrong, when I can’t connect the network folders on my mybook?

I always have to enter user and passwort (in a windows style window) and nothing of all possible entries is working. Neither admin and pw, nor any username and pw etc.

When I enter the PCs username and password, it sometimes appears like another window, where it looks, as if I am on the last step to enter mybook, but nothing works. So now, I can only acces the “open” network folders, that are not set to private.

Thanks for any help!!!

Within the MBL you can assign different users to different folders, but for the default, the username is “admin”, followed by the device password. 

When you originally set the device up, it should have prompted you to set a device password, but if you cant remember it, just perform a reset on the MBL, using the instructions here:


The master reset wipes any settings (including passwords etc), but keeps the data on your drive. Its always good to have a backup of the data on the MBL anyway just incase things go wrong. 

1 Like

 Lightingman2003 -  You nailed it.  All is working fine.  Thanks

Hello and thank you for your help.

It seems, that all my “mobile problems” were just caused by the old router.

I have installed the new one and as much as I can tell, the mobile access is working now.

Still have to test it in my office and need answers from my brothers who have to test it too, but it looks fine.

One last question I have, related to the passwords:

When I enter my network with my laptop. How does the MBL see, who I am? Is the login from the WD browser interface stored somewhere? Do I always have to log in by using the browser interface?

What, if I now use a new laptop in my network. What folders from the MBL will I see there and if I don’t see anything or only the public folders (what I hope, is the answer here), do I have to log in on the browser, so the network paths will be opened?

Thank you!