Device Offline - not accessible message

I am having intermittent (more off than on) problems in connecting with my iPad and my new My Book. On WD2go, when I try to connect the My Book Live to see my Shares, I get a message saying ‘Device offline - The device is not accessible’. The My Book is blinking green - does the WD2go only work when My Book is not doing any other backing up etc? Can anyone help?

Is your MyBookLive updated to the latest firmware? 

It better be because previous firmware versions had some issues regarding remote connections using WD2go.

So, login to MBL user interface, go to System->Update and check online if any update is available.

I’m having a similar issue here - same “device not accessible” message on WD2GO app for not iPhone and iPad.

The app works perfectly when I’m using any network other than my home wifi to connect (i.e. works fine over 3G, over work WiFi, etc). But when I’m at home, with my iOS device connected to the same wifi router as my MBL (which is using the latest firmware), I get the “device is not accessible - local files are available” message.

So far, I’ve rebooted the router to default settings, switched off and on the Remote Access in The MBL dashboard, reinstalled the iOS apps and re-set up access within the apps (new PINs etc).

Any ideas what I’m doing wrong? I’d like to be able to access the MBL with the WD2GO apps whilst at home but this isn’t really an option if I have to use 3G to do so. I want to stream videos and view large images on the iOS devices and 3G is too slow.

There seems to be an issue with some Routers that makes the ethernet/wifi connections act independently. I’ve so far only seen it happen on iOS devices, however it could potentially occur on an Android as well.

You’ll want to switch your My Book Live to Relay, which will force a remote access connection. That will make the App see the My Book Live remotely instead of locally, so it doesn’t try to connect to it locally.

We are investigating the causes for this, btw, so if there is something we can do on our end we will.

To switch to Relay, just disable uPnP on your Router and remove any Port Forwarding you’ve set up.

Hi Laura,

I posted a question as new topic but I saw this thread that is kinda similar to issue that I am having.

My concern is: if I switch off UPnP, would that affect network settings? I have few laptops (Windows), WD live duo, Apple TV, iPad 3 and iPhone4.

I was actually thinking to do opposite thing-to add port forwarding for WD photos app and WD2GO pro app. How to do that!? I know how to do it for Web access but not sure for iTunes apps.

FYI: some other iphone/ipad apps that I am accessing WD live Duo are working flawlessly so this might be WD issue after all.

Thanks.

I am having a similar problem - the disk keeps going offline periodically and then reconnects again after about 5 or 10 minutes, although it often needs to be triggered somehow. It happens when I am on my Mac on my home netwok, and also when I am on my iPad out of home, even when in the middle of downloading something, so it is something to do with the disk not staying online all the time, and not to do with going to sleep when not in use. Anyone got any ideas?

I am experiencing the same issue as everyone else acontacted support support three times. Woks at  home but does not work remotely.

I’m having the same problem, I even can’t access my drive via browser anymore which worked fine for a few days… What’s going on there? Could you please let us know if you’re already working on this or if you already know what’s causing that problems?

I have same problem. I contacted to WD support and I am waiting for a reply.

I haven’t got any problem with Microsoft network access.  From a windows PC, I can successfully map drive to every share in MyBookLive.

iPad uses wi-fi local connection and it can ping MyBookLive’s local IP address. There is no firewall.

MyBookLive information :

- Firmware is "02.32.05-046"

- LAN configuration is correct, IP is static.

- “Internet Access” is "Good"

- I enabled "Remote Access"

- “Connection Status” is "Connected"

I created a code for " admin" in " Mobile Devices" and I added MyBookLive to WD2Go app, I entered activation code.

Then a " Device Offline - This Device is inaccessible only local files are availabler" error appears.

How do I disable upnp on my router???

Laura, 

This is not serious. Not all your customers are IT pro. It took me 2hours to start the NAS - I had to reset the factory setting -although it was brand new - and now I can’t access it from the wd2go app. “the device is not accessible”. I have a box - my router cannot be configured as such…this is a shame. I’d be ashamed to offer so NOT USER friendly devices and UNSTABLE apps. 

Please let me know if there is a solution or if I better return your product to the store and buy your competitors.

Mehdi

MBL needs to acces WD servers on internet because it must create a login code.

I think, there must be an inbound NAT redirection in router which enables WD servers to access MBL back.

I tried many ways to access to MBL but I couldn’t.  Finally, I tired to work on this basic case for days.

I purchased “File Browse” (Stratospherix) app for my iPad and I can successfully access shares in my local network.

Hi,

I got the same problem with my just bougth my book live 3TB. Yesterday I installed the device and moved my files to it. Tested access with iPad, my smart TV and Android phone. WD2go worked like a sharm, could show photo’s and videos.

Today, I grab our iPad to show off some videos and now WD2go gives “Device Offline”!?! On my android phone WD2go still works and accessing the MyBookLive shares from windows 7 also no prob.

I would expect that a consumer product like this just works out of the box. What 's going on here?

Please give us well explained solution to this problem.

Regards

I hate to say that after a year of fight with different glitches (for a year now!), I gave up using iPad apps. It’s always something that is a problem…and some other apps work flawlessly. 

I will wait for WD to fix it (make it more stable).

Good luck to us all.

When starting the WD 2go app, in iOS at least, the app does an immediate mDNS (multicast DNS) query to the paired hostname of the WD 2go server.

For example, I have my app peered with an MBLD named BIGNAS3

I see an immediate mDNS query for the hostname BIGNAS3.local.

The query is sent using IP Multicast Group 224.0.0.251, using the ethernet multicast address 01.00.5e.00.00.fb.

If something in the user’s network is not properly forwarding the multicast packets, then it’s going to fail to find the device “locally.”

It may be that some people’s routers / Wireless APs do not handle multicasts correctly.   That’d be a pretty serious problem.  

Anyway, if mDNS lookup fails, the app will then try to find the registered name of the device using regular DNS.  The registered name is assigned by WD when the WD 2go “Server” (MBL, MBL Duo, N900C, whatever) is set up for web access.

In my case, it’s BIGNAS3.deviceXXXXXX.wd2go.com.

That’s an EXTERNAL name, and is globally registered, so DNS will respond using the EXTERNAL address of the router, in my case, 96.226.xxxx.xxx.

My router is “smart” enough that, even though I’m trying to access an “external” address, my router will still re-route the packet back into my LAN according to the Port Forwarding rules defined either via UPnP or manually.

Finally, if the user’s defined DNS server is NOT able to resolve that name for some reason, connection will ultimately fail.

So, in summary, there’s three things that need to happen to connect correctly.

1- mDNS must work in the user’s home environment.

    To Test:    On the iOS device itself, bring up a web browser and surf to the name of your device with a “.local” extension.  For example:   “BIGNAS3.local”.   If it works, you should see the web manager of your device.   

2- DNS Resolution must be able to find your EXTERNAL name using YOUR DNS. 

  To Test:  Well, you’ll need to find out what that name IS.   Easiest way to do that is to log into your drive via WD 2go from OUTSIDE your network using a PC, and note the URL.

  Then, come back INSIDE your network, and do an nslookup on that name.

Example:

C:\Users\Tony>nslookup bignas3.devicexxxxxx.wd2go.com
Server: (deleted)
Address: 10.0.0.1

Non-authoritative answer:
Name: bignas3.devicexxxxxx.wd2go.com
Address: 96.226.xxx.xxx

 You need to make sure the address matches your OUTSIDE IP address on your router.

3- Finally, see if your router will do “Inside-Out-Inside” routing.

On your device’s browser, browse to the EXTERNAL NAME of your device, with :443 at the end.  Something like

BIGNAS3.devicexxxxxxx.wd2go.com:443

If you get a response that begins with

Bad Request

Your browser sent a request that this server could not understand.

… then it works.

Is there any further update on this issue?

I am unable to view any shares via ipad or iphone in our outside of my home network the “share list” in the app remains empty. I am able very slowly to pick up photos via WD Photos on both devices.

Also I am able to connect to my MBL via FileBrowser by Stratospherix but I am obviously keen to make use of the WD Apps.

Any further updates gratefully received.

Thanks

Hi,

Not sure if you have been able to resolve your issue or not.  I had the same problem with WD2Go on all of my iOS devices.  I worked with WD’s excellent Customer Support people.  The issue was tricky enough that I was forwarded over to their Level 2 support agent.  The solution is this:

After the firmware upgrade, you need to reset the server (in my case it’s a brand spanking new My Book Live Duo) to Manufactuerer’s Default.  The reason why this needs to be done, according to WD’s support agent, is to restart some lower-level services that may not have been started after the firmware upgrade. 

Before you jump in joy, there is a catch.  When resetting the server to Manufacturer’s Default, you will lose all of your data.  So you’d need to back up all of your data first, reset the server, and then copy all of your files back to the server.  If you have gigabytes or terabytes of data, this can be a very long procedure.

However, once this workaround is applied, WD2Go works without a hitch.  I am able to access all of my files on my server from either my home LAN or remotely from the internet.  Absolutely flawless now, but the path to get there was painful for me.

Cheers.

I have finally managed to resolve this issue with no loss of data by following the instructions in the first two pages of the thread:

http://community.wdc.com/t5/My-Book-Live/new-My-Book-LIve/td-p/299058/page/2

Hope this helps someone else.