Very dissapointing product

Just purchased a My Passport Wireless Pro. I spent an hour trying to figure it out. My use case is simple… copy SD cards to the drive without another device. I couldn’t get it to work. I am a software developer so technological illiteracy is not the issue here.

Some of the problems I had:

  • After booting up the drive and connecting my phone to it’s hotspot, I tried copying an SD card by pressing the SD card button. I held the button for 2s. Multiple times, no response.
  • The device crashed twice in this first hour I’ve been trying it. All LED’s start blinking and the device froze. The first time I couldn’t even power off.
  • Eventually the SD Card copy started (I think?) the 4 battery LED’s lit up solid continuously and got stuck in this mode. A folder structure was created but no files copied. Not sure how we’re even supposed to monitor copy progress ? With the LED’s ? This is clearly not working.
  • Tried switching the wifi network to my home wifi at this point. I entered the password of the wifi in the webadmin but then nothing worked. I got kicked out of the hotspot, with “PW Incorrect”.

Terrible experience over all! I wish I could return this immediately.

I think your drive may be having problem. It doesn’t sound like the SD card was getting copied based on the description. You can check if the file system on your drive is dirty and format it to NTFS if needed. I would contact the WD Support team directly for help if this doesn’t work.