USBDeview sees Elements SE drive, disk manager and Explorer don't. Looking for driver

Light comes on, disk spins, but can’t see in Explorer or disk manager. USBDeview says it’s connected, though. I’ve had some issues lately with drivers getting fried, so I’m wondering if that might be the issue, but I can’t find any drivers. Any help is appreciated.

 EDIT: I already tried on multiple machines and with a new cord. Still no change.


Test the drive on a different computer and also try a different cable. 

Tried both, still doesn’t work.

Sorry I didn’t include this information in the original post.

The WD Elements is a plug and play drive and it uses the generic USB drivers.

How is the drive showing on disk management? Does it have a letter assigned?

It does not show up in disk manager or Explorer.

This is why I’m stuck on the driver issue–a couple of weeks ago, when the drive failed, I was trying to get it to work and I plugged it in and turned on my computer. The computer would not start. After ten minutes, I forced a shutdown. Now, I don’t know if it was a coincidence, but sometime around then I lost the drivers for both my touch screen and my ethernet connection. I didn’t notice for a bit because I don’t use the touch screen that often and my computer just switched over to wireless. Now, maybe it’s a coincidence. But it’s the only odd thing that happened so I thought it might be significant. 

Do you know what I would look for in Device Manager to see if it still has the driver?

If the USB port still works, and particularly if other USB drives still work then you have the driver.

As noted above it doesn’t use any specific drivers (that’s the difference between the Elements and MyPassport drives - the latter uses the WD SES driver for it’s advanced features like security and encryption).

But if the generic driver is missing then there should be a ? under USB controller (or something similar) in device manager, or more likely your Windows installation should just reinstall it as it will detect your computer USB ports now as new hardware and reinstall the driver itself.

The computer probably wouldn’t start before as it may have been able to see the drive enough to trying to use it as a boot drive (depending on how your computer is set up at the BIOS or equivalent level), but as it couldn’t access it enough to see that it’s not a boot drive then it hung whilst trying to do so until you forced the shutdown.

So if it’s not the driver, where do I go from here?  (When I get home I’ll check for the ? under USB controller, but I don’t remember seeing anything like that before.)

Inside the drive there’s a circuit board which the cable connects to which has all the hardware on it for the actual control of the drive itself, and the actual drive connects up to this. My suspicion would be that the USBDeview is able to see the drive due to seeing this circuitry, but that circuitry cannot actually interface properly with the drive itself (the actual hard disk, drive heads, platters etc) to read the data off it, hence why disk manager and explorer can’t see it.

If that is the case then personally I would say your drive has perhaps suffered a (mechanical) hardware failure on the drive itself. If that’s the case then you would need professional assistance to recover data from it. Normally if it’s a data or partition corruption on the drive itself then it would show up in disk manager or sometimes Explorer, even if it cannot be accessed by them.

If it were me and there’s data I vitally needed on it I would consider a recovery company assesses it, or if not it’s an RMA job (I would certainly not advise trying to open it yourself, as you will void any warranties and probably do more damage). However others may have other ideas or things to try before that.