Unable to Uprade Firmware to 02.43.09 -038: Error 30005

I’m currently running Firmware 02.43.03-22, according to my WD Quick View menu Properties viz.:

My setup is that I use the MBL with a number of Macs (iMac and Mac Book Pro).  I used to use it for Timemachine backups, but it stopped working around Mavericks, so I replaced it with a Time Capsule.  However, it later recovered, and I keep the old Time Machine backup and restore from it when needed.  I also use it for backing up my Bootcamp partition on my Mac Book which is running the current Windows 7 Home. 

This firmeware was replaced by 02.43.09 - 038 on 21st January this year. 

I’ve followed the instructions http://www.wdc.com/wdproducts/updates/?family=wdfmb_live to upgrade - ie. use the dashboard, but I get the following error:

ie. "Error. 30005 Unable to retrieve data. Make sure that there are no network connectivity issues and try again.  "

The erorr is nonsensical, in that I have a fully functioning MBL with no connections problems whatsoever EXCEPT to the settings menu of the Dashboard.  If I try the update opion within the Quick View menu it just goes away as if it’s working, but nothing happens.  I know how to update manually using ssh (Through ssh I can enter the drive, list directories and run commands without problems), but the instructions say that manual updating is not available (when did this stop?), and in any case I can’t find the firmware file. 

WD Support said that I should:

  1. Power cycle
  2. Soft reset by pressing and holding the reset button (pinhole above the Ethernet port) with a paperclip for 10 seconds.  After this the device will obtain a new IP address and set the configuration of the drive back to default without deleting files.
  3. Taking the My Book Live to another Internet environment like a friend or family member’s house and see if it works then.
  4. Aas a last resort you can try the following: Try performing a factory restore to the unit in order to restore the drive configuration to factory and correct any allocation problems on the sectors of the drive. In order to perform this task on the dashboard of the My Book Live go to Settings/Utilities/Factory restore.      Important: Before performing the factory restore please make sure that the My Book Live has no files stored on it due that this process will erase all data stored on the My Book Live.

I’ve done 1 and 2 without success.  I don’t have an option for 3, and I don’t won’t to try 4 becuase I have a fully functioning drive.

What should I do? 

Having the same issue. Upgrade process stops at 10% and sits there for 10-15 minutes, then gives the same error.

WD, what the heck is going on? Never had issues with the drive, but now I cannot upgrade it.

I want to upgrade it because every night at 3:00am it reboots for some reason. Hope the new firmware will fix the issue but I cannot upgrade it…

Something is corrupt.  Use one of the debrick guides on this forum to reinstall firmware.


Thanks for the advice.   Debrick Guide 2 seems the right one for my 3TB MBL.  Is that correct?

Now, the Guides begin with the following warning: 

“Be aware that this will void your warranty and is only to be used as a last resort when you have no dashboard or SSH” (my emphasis)

Now, I have some Dashboard functions (all, in fact, except the settings menu) and I have SSH working perfectly. 

Are there some debricking options that I’m missing, which are used in non “last resort” situations with Dashboard or SSH?  For instance, since I can communicate with the drive via ssh, is there a command that I can do from the Debrick guides or elsewhere that will, for example, roll back my firmware to an earlier version, and then reset the drive so that I can then roll forward to the current version?  Your suggestion seems to imply that all I need to do is reinstall the firmware, but I can’t see this option in the debrick guide. 

I have tried installing Firmware Version 02.11.09 – 053 which  according to WD is the minimum starting version for the current install, but I just get a 200 Error in SSH -

error="failed 200 \"invalid firmware package\""

I seem to need to rollback my current firmware version first in some way to avoid this error.

Sorry if I’ve missed something obvious.

Thanks again,


Since you have SSH access and dashboard, you can use it to trick the MBL into reinstalling the firmware.  This is much easier than debricking since you don’t have to take the disk ouf of the drive.

There are instructions on how to do this on this forum somewhere.

I think it is

echo “02.01.06” > /etc/version

and then use the dashboard to do an upgrade.

this guide



Thanks.  That looks much more promising, and involves rolling back to version 023205-046 (one after 053, which they also recommend) using a somewhat different method, and they specifically claim it does do downgrades.  I’ll try Guide 2 (manual method), when I get a chance, as I’m too tired after Easter to try something this technical late at night.  I’ll get back in a few days on how I get on.

Thanks again.


I never did get around to providing feedback to the group. I’ve now forgotten the details of what I did, but I think I managed to avoid the 30005 error on the Quickview Dashboard, by logging direct into the My Book Live and updating the firmware manually.

However, a year and a half on, I have a quandary.

I’m not sure if my firmware is up to date. The latest firmware is 22nd June 2015, while my post was from April,2015 so it looks like I’ve not installed that update, though I can’t be sure. However, when I check, I find that the firmware version is no longer available:

Previously (see early screenshot above), the version was available in the Properties panel. Maybe this is because of the change to Windows 10 (I’ve just upgraded to 10, which prompted this review of my firmware and software). Does anybody know where I can read off the firmware version that I have installed, now that the Dashboard Properties panel no longer displays it?

Some may ask why I don’t just update the firmware anyway. Well, it goes back to my previous problem - I have a fully functioning My Book Live, actively used for backups and with fully updated software, including Dashboard EXCEPT that I still can’t access the Settings Menu of the Dashboard to make firmware updates. I get the 30005 Error, suggesting there is no connectivity, whereas everything except Setup is fully connected and functioning. Obviously, I don’t need to disturb the machine and go to the great trouble and risk of manual updating unless I’m sure that my firmware is, in fact, out of date.