Unable to connect to My Book Live via browser

I don’t know if anyone else is experiencing this problem, but I’m unable to connect to my My Book Live via a browser. I can connect to it locally (it shows up in my network) - I can connect to it via the mobile app. But if I load up Firefox/Chrome/Edge - it will not connect, I just get the page as attached

This is annoying as I sometimes grab files from my drive whilst at work; now, I have to load up the mobile app, download it to that and email it to myself, which is annoying.

It’s been like this for about 3 or 4 months - anyone else having similar issues?

Is this Windows, Mac or Android?
What are you using as an address in the browser to get to the MBL? The IP or http://mybooklive ?

I can access the dashboard page through the http://mybooklive site. The problem that I have is trying to access the files through the URL https://files.mycloud.com/login.php which I’ve always used in the past. I’ve even reset my password, removed access to my email through the dashboard and re-enabled it. Tried it on 3 Windows PCs (2 on Windows 7, 1 on Windows 10) and a Mac. All show the same error page when trying to access through a browser.

Has WD removed the ability to remotely log in to the My Book Live via their web-based login page?

OK I see now…I haven’t been able to use that in quite sometime on mine. Pretty sure it’s no longer supported. I know there is a setting in the dashboard under Steetings>Remote Access. This has to be enabled and you need to have a successful “connection status” indication. This is what I can’t get to happen any longer. We used to have to use wd2go.com for this purpose. Now using that address you get redirected to the site you mention above which doesn’t seem to work with the old MyBookLive.

This is annoying - as they haven’t stopped remote access via the mobile app. It seems that they had dropped support for the browsers now. I don’t understand why they would remove access to it via a browser if they clearly still have the infrastructure there, able to do it (else the mobile app wouldn’t work).

And all you get from them is “this device is no longer supported” when you contact them.

I have a similar problem with my “MBL”. I can see it on the network but I cant open it with a browser. I am able to ping the device IP with a “ping” command prompt. The MBL light is steady green. I am using my desk top Windows 10 pro. I’ve enjoyed the WD Mybook live NAS for some time but this is very annoying. Hope you find a solution.

1 Like

With a browser you should be able to get to the login page for the dashboard. Just type the ip of your unit into the browser’s address bar like http://your_ip or use http://mybooklive. You should come to this: