MyBookLive Web access timing out

I have set up MyBookLive and all seems to be working ok.

I have been able to access this from my PC, iPad and iPhone (using the WD2Go App) however the one thing that doesn’t appear to work is accessing the drive via

I can log in ok, I can see my drive, the moment I try to click on it, it looks like it is doing something then I eventually get a time out error.

Now at this stage I have not tried it on a computer external to my network, but I would have assumed that it would still work to an extent, if nto mounting the drive via the java applet?

Be sure to download the latest java update, also check if using another web browser works.

Java is bang upto date and I have now tried this from a remote laptop using a DSL connection unrelated to my network and the issue still occurs in both IE and Firefox.

Is it possible the router is somehow blocking the connection? I am not sure how or why because the mobile app works, unless of course different protocols or ports are used when trying to access this via a computer compared to the app.

In a shameless bump…

Has anyoen else come across a similar issue when trying to connect remotely to their MBL using the WD2go portal?