Twonky server does not index

I have all my media in /Public in the default directories of Shared Music, Shared Pictures and Shared Videos.  The default setting of the Twonky server to index Public worked fine, but I didn’t like the way it pulled album art out of music.

I changed the sharing settings from /Public (All content types) to /Public/Shared Music (music), /Public/Shared Pictures (photos), and  /Public/Shared Videos (videos), and saved the settings  It started indexing right away.

An hour later it found no videos, a couple dozen songs and less than 100 photos from a collection of 10K files!  I’ve restarted the server, rebuilt the index, etc to no avail.  Change the settings back to /Public (all types) and it finds everything again without problem.

What am I doing wrong?  Why can’t I restrict sharing to certain folders of certain file types?

That’s exactly the problem I had.  Here’s how I fixed it:

I got rid of the 'Shared ’ part in the media folder pathnames.  In particular, it seems to be the space that causes problems.

Also check that, if you’ve done a recent firmware upgrade, that media serving is enabled on the Public share.

Note the comments about how MC and Twonky don’t play nice…

I have disabled automatic firmware updates to prevent my Twonky server being broken…

1 Like

Thanks for the great response