Traveling with MBL 1tb

Sorry for what may be a real noob question but I want to try something without breaking what is working so well.

I have ipad gen4, MBL 1tb and an Airport Express router.  Right now the MBL is plugged in to my home router and the Airport Express is still in the box.  I will be stationed for an extended period to a place with no  permitted way to link to internet with personal devices and no cellular.  I propose plugging the MBL into the Airport Express to make my own little network but not have the router plugged in to any upstream internet source.  Is there any reason this would not work?   And if it will, are there any precautions to be taken when switching back and forth between the dead-ended traveling router and my home router?  Would a pre-departure test be a simple matter of  unplugging the MBL from the home router and plugging it into the dead-ended traveling router?

Thank you for any help.

Nope, there shouldn’t be any problems.

Well I disconnected the home router used for initial install and connected MBL to a new router.  When I try to access MBL in WD2go app I get a message saying “This device is inaccessible; only local files are available”.  So I can see the files previously downloaded.  The new router is not connected to the internet as is required in my case.

Interestingly I can access the MBL by navigating to it on the new network via  http://mybooklive.local/UI/#.  This shows all access and permissions as before.

I had a feeling this would not work but don’t know enough about this stuff to put my finger on the problem.  I have powered down and powered up the MBL while connected to the new router to no avail.  I have not tried the reset button.  The new router is an Airport Express.  The initial setup router was an Airport Express Base Station.    The MBL was innitiated with a Windows XP laptop.  On the new network I am only using an ipad4 and the MBL.

Any suggestions folks?

I don’t think it’s going to work the way you want.

The WD 2go app needs to be able to “find” the MBL when it connects to it, and I think it uses WD’s servers to do the initial connection.

You can try this:

UN PAIR the WD 2go app from the MBL via the app itself.

Then try to discover it again on the new router by doing the “Connect Now” button.   See if it can find the MBL and pair to it.

Once that’s done, see if you can access it.

Thanks for the suggestion.  Unfortunately this did not work and the WD tech support tells me that any network allowing mobile devices to access the MBL always has to be connected to the internet  even for local access to be possible.  Unless I can find another app that will get me from the ipad to the MBL in a local network I’m cooked.

There are other apps you can try that might fit the bill, such as FileBrowser…

Thanks.  This looks great.  

But. Oh my, the ipad’s broken.  For some reason it thinks I’m a developer and I need a “sandbox” account.  Too much playing around with networks?  I have an appointment tomorrow morning with some guy on mountain time.  If software reload does not work I get a replacement ipad.

Before the appointed call I fixed it myself.  I will recount the procedure in case anyone comes here looking for a solution to this problem.

Established the problem;   when the iPad became un-paired with the MBL  and then floundered around while I tried to re-establish it on a new network with no internet connectivity it tricked itself into thinking that it was in the hands of a developer.  My Apple account was then frozen for the iPad only.  A message came up saying that I needed a “sandbox” account.  The specific problem was, I think, that the WD2go app always needs to connect to WD servers on the internet even to link local mobile computers to the MBL. 

The first thing I did was  use the WD control panel in a local web address to un-link all my mobile devices from the MBL.  I left all the shares alone.  I was unable to re-link on the new network with WD2go without internet connectivity.  My Apple account still worked on my iTouch.  I noticed that, even though my account was frozen on the iPad, any apps purchased on the iTouch synced to the iPad automatically.  I downloaded an app called File Browser to the iTouch which also appeared on my iPad.  I established that File Browser was able to connect my iTouch to the MBL on the new network without internet connectivity.  I then used File Browser to re-link the MBL to the iPad.  Care was taken to use the same password to the device, user name, and password that were established with the WD2go app on the original network.  This gave access to everything that I loaded onto the MBL on the original network including private shares.

It turned out that, by re-establishing the link between the iPad and the MBL, the iOS on the iPad saw the error of its ways and everything is back as it should be.  I can easily switch between the network with no internet connectivity with the MBL on it to another network with internet connectivity.

Anyone wishing to use a MBL with mobile devices on a network with no internet connectivity and no computers on - should use the File Browser  app and not WD2go.  If you made the same initial mistake as me, and you are working with iOS devices, the above procedure should fix the problem.