Transmission Web Login No password


#1

How can I enable a password? I can access transmission from anywhere by entering :9092

I’ve used PuTTY to SSH in. transmission-daemon has options to require authentication and to setup a username and password. So I’ve done all of that but it doesn’t seem to have made the slightest difference. I’ve seen on one guide that i need to use ‘transmission-daemon stop’ first, and later restart, but this doesn’t seem to have done anything either. Can anyone give me a rookie-proof step by step helping hand on this please?


#2

Hopefully an experienced User will be able to assist considering there’s no official WD documentation available related to what you would like to accomplish.


#3

Cheers trancer. Giving this a bump in case any member of the community has any info on this. I’m a bit uncomfortable having this just hanging out there with no password protection on at all.


#4

I’ve just had a play with this again and none of the options from transmission-daemon seem to have an effect. I tried to just set localhost on the white list but it’s done nothing. I tried to set the default port too. I don’t get an error when running the command, but when I check in the web side of the client nothing has changed.
There must be someone else who has used this, I can’t believe that everyone using transmission just has it open for anyone to access.


#5

Hi,

What kind of WD device do you have. Mine is EX2, I run into the same challenge as you and this is how I overcome it.

  1. First you need turn off transmission service, you can easily turn it off from your device web interface.(Apps --> Transmission --> set Run Apps to off ).
  2. Log in into your WD device via SSH, if you don’t know how you can read on this link http://support.wdc.com/knowledgebase/answer.aspx?ID=14946
  3. Find your transmission settings.json file using this command find / -name settings.json
  4. Once you find the location of the file open it using any editor available on your device, but I think vi is your best bet.
  5. Set rpc-authentication-required and rpc-enabled to true, Set the username and password you want to use in rpc-username and rpc-password respectively.
  6. Save and exit the settings.json file
  7. Turn on the service and you should be asked for login if you load the transmission web page.

Good luck and let me know whether this is work for you.


#6

That would have worked! Because the problem was that I wasn’t looking in the right places.

But I think I should say what happened here and why I initially failed following many posts and guides, because this was a bit of a pain.
I’d installed transmission using the WD GUI. Some of the guides knocking around I think are for different installations, because none quite accurately described what I had to do… not helped by a rudimentary knowledge of linux.
So, it seems I’d kicked off processes trying to set passwords using transmission-daemon -u transmission-daemon -p because the actual transmission process on my installation (which I found out using “top”) is transmission-daemon-addon So whenever I was trying to stop the process, like i described in my original post, that wasn’t working either.
Once I established that I was able to disable the process, I was also given the location of the process, and from there I found and edited the json and finally get my password setup.
I just need to go back in now and set a few other bits like default download folder, and bandwidth allocation. Because making changes in the GUI all get reverted if I power down the box.
This took me ages to sort, cos I’m really inexperienced with linux, but was pretty ok with DOS back in the day, but there’s subtle differences in things like the cd command from DOS to linux that I didn’t figure out and so I kept thinking that I had admin issues navigating around the file structure…


#7

You are the KING! :slight_smile: thank your help!!! :clinking_glasses::grinning: