Transmission dont work after today system update to 5.27.157 on WD My Cloud EX2 Ultra

hi, i have a big problem, major issue is with transmission problem, after automatic system update tranmission wont start (after today system update to 5.27.157 on WD My Cloud EX2 Ultra )

i try:

  1. reboot
  2. power reset
  3. stop and start at wd menu
  4. stop and start at ssh
  5. changing transmision settings like here Transmission doesn't work at all - #16 by Sababapo
  6. reinstall app from wd menu

no of upper solutions wont work for me Service Unavailable and when i try to get to transmision link i get:

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

please help ! its so important to me right now

Have you been offered the newer version of Transmission? It needs to be updated but updated versions were only offered sometime after the system update.

I don`t have new version … and have not any apps updates… I think WD recall firmware and updates…

Hi, Transmission become totally unresponsive after upgrade, Setting pane comes up for 1 second and disappear.

Same issue led me here.

There is workaround actually, I applied to my MyCloud and put Transmission back to life.

Downgrade.

Here are files needed: My Cloud OS 5 Firmware Release Note 5.26.300

Just choose appropriate one, download it, log on to your own mycloud local webpage, disable autoupdate and “upgrade” firmware using file downloaded.

1 Like

i found a solution for me without a downgrade

first clear cookies in chrome/ other web browser (transmision www link etc 192.168.1.10//transmission/web/)

then login in to the wd nas and tunr off transmission
next turn on and wait a while, log off and log in to wd nas
should be a option to upgrade transmision to new version (from 1.15 to 1.16 via 3.0 )
but i lose all added torrents (task) that i recomend to copy all torrents from copy folder

I am having the same issue. I’m trying to downgrade now. I keep my transmission settings on my share, not on the root so I didn’t lose anything. I hope that downgrading the firmware will keep the new transmission version…?

I’m attempting to connect with 3rd party clients which worked perfectly before but now they don’t. I hope that they put out a fix soon.

I’ve been having exactly the same issue since the firmware upgrade. I turned off Transmission, and then after a few hours it offered me to upgrade from 1.15 to 1.16 and that fixed it last night and this morning. Now however it’s doing the same thing on 1.16 and saying the service is unavailable.

After I downgraded, the option to install Transmission is not there at all. It’s completely missing from the app store. Is there a manual download somewhere? Thanks!

remove old cookies from web browser

It is.

Here: My Cloud OS 5: Download and Install 3rd Party Apps Manually

Edit: here as well, but without manual - My Cloud OS5 Apps Download Links

Thanks. After the upgrade to the latest version, I was able to connect to the web client but not the rpc which I need for connecting through remote apps. After downgrading to the previous version, I still had 1.16 installed and it would not connect at all. After I downgraded both the firmware and the transmission version back to 1.15, it worked normally again.

I have therefore disabled automatic updates. I’d appreciate it if someone can post here when a fix is available so that I can upgrade.

In the process, I also lost everything. 3500 torrents.

1 Like

3500??? Wow, that’s an awful lot of stuff, I’d say.

Luckily for me no torrents were affected during the whole thing, probably because I didn’t get 1.6 instead of 1.5 therefore did not have to downgrade Transmission after firmware downgrade. I did, however, reinstall Transmission 1.5 while trying to troubleshoot the issue and that did not wipe off the torrents either.

Hello, Where can I get the transmission bin file? Because I don’t have it on the list of programs to install after restoring the previous software

My Cloud OS5 Apps Download Links - My Cloud OS 5 Personal & Network Attached Storage / Community Developed Apps - WD Community

HEY! I have the same problem, my app transmission (1.15) doesn’t work. I’m seeing: Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Maybe somebody found answer for this problem ?!

Same issue for me- the setting of 1.16 disappear after a second. The next problem for me is - ever, when I edit the hosts-file over ssh, my changes are away after a reboot. Does anyone know a solution?

Thank you in advance.

It`s not working with previous firmware!

Hi, I’ve just succeeded in getting RPC access to version 1.16 and wanted to share my setup.
First, completely uninstall the existing version 1.15 and install version 1.16 anew.
Then disable the app after completing the user account setup required to access the web client.
Using WinsSCP, open the "settings.json’ located at ‘/mnt/HD/HD2/NasPg/Transmission/config’. (You will need SSH setup beforehand to open that file.)
Change “rpc-bind-address” to “0.0.0.0” and “rpc-host-whitelist-enabled” to ‘false’ in the middle and save it.
Then enable the app and try to connect via RPC.
I was able to connect successfully with this method.

Adding more information just in case someone encounters the same problem as Transmission went completely dead in the new firmware update. The cause on my end is that transmission-daemon couldn’t reconcile with the latest curl libraries installed (which is v7.74). I downgraded my firmware back to v5.26.300 and installed Transmission v1.15. To solve the whole mess.

MyCloud OS v5.26.300

Transmission v1.15
https://downloads.mycloud.com/os5-apps/apps/GZA/GZA_WDMyCloudEX4100/Transmission/WDMyCloudEX4100_Transmission_1.15.bin

P.S. I lost thousands of torrents after making a backup mistake putting it in the home folder of root. Silly me. Make sure you store it to a different drive.