Transmission doesn't work at all

The transmission app should redirect the IP_ADDRESS to your device-local-XXXXXX ID.


1 Like

I know, but it doesn’t.
The opened page remains blank.

@SBrown this doesn’t work. Blank page on the browser I’m already logged in on, and error 403 on any browser I’m lot logged in through the admin page on already.

Direct links such as

Or any combination of the above or other direct links do not work.

The only way to currently access transmission for me is to login through the management page, go to apps, click on transmission, click on the configure button, and it loads a new tab for it. After a few minutes this tab will time out and refreshing it at any time results in an error message. The only way to continue the session is to repeat these steps in full.

Can you provide a solution, or a date for a firmware rollout to resolve this issue?

I even can’t get to open the link via the “configure” button

1 Like

That’s rough. I hope they provide you a solution soon, because so far the rollout of this has been a disaster. Everything from feature removal, to poorly explained reasons for why, to lackluster responses of “will be supported soon” for Transmission, and then even “this will take some time” for Docker support. It’s all a total mess.

Their community staff are basically giving “sorry not sorry” responses to a lot of the threads too, but I do honestly feel for them in a small way. They didn’t decide to roll out this disaster, and they are the ones left feeling the anger of the community as a result.

I know one thing though, they’ve lost a lot of loyal customers because of this deployment, ones that their competition will be happy to pick up.


WD announced they are doing something to improve the auth system so there are less problems.

In the mean time you can use uBlock Origin to force block the remotewd redirect if you use advanced mode:

I too found a way to block this using uBlock Origin, huzzah!

You must have advanced mode turned on in the extension settings and then when you navigate to YourIP for your NAS you configure the settings like this:

Once this is set, using direct links like MyIP/apps/transmission/web/transmission.html works without having to go through the admin panel and navigating to the app configure first too! Great success!

My point is that when I click on the configure button:

It appears just a blank page:

No transmission app available, just this blank page!
How can I solve it?


Have you tried waiting longer? I have a similar issue - when open Tranmission it shows a blank page, but after 20-30 seconds it loads finally. I notified WD Support about this lag problem.

you should log in to your NAS before try open Transmission … it want let you after WD new update

Still can’t access it with firefox.
I had the chance to acess to transmission using edge for two days, but now it seems it doesn’t work even using edge.

I’m at the edge of a nervous breakdown…

Let me go back to the previous firmware!!!

What error do you get ?

When i click on the configure button it opens a new page at this address:

but it remains blank, no access at transmission at all

After the update from os3 to Os 5 did it work at all for you ?

it worked for two days, using EDGE, but now it doesn’t work anymore.
using FIREFOX, it never worked after the upgrade.

Can you try that ??

Step by Step :
1- Login to NAS => Settings => Network
under “Network Services” enable SSH (JUST for the changes and at the End Disable it again)

2- open PowerShell (run as Administrator)
3- write “ssh sshd@yourIP” - ask for password and then login
4- write “cd /mnt/HD/HD_a2/Nas_Prog/Transmission/config”
5- write “ls” (just to check if you can see settings.json) if you c you continue …
6- write “vi settings.json” (vi is a is a text editor)
7- look for that line rpc-bind-address:your IP
8- press “i” for insert mode (i is let you to Edit the file)
9- change to “rpc-bind-address:”
10- press ESC to exit insert mode
11- write “:wq” to save and quit (need to type :wq )
12- write “pkill -HUP transmission-da” then Enter (to kill transmission running)
13- go to admin and stop/start transmission
14 - close SSH mode

15- on Browser paste that “http://your/ IP:9091/apps/transmission/web/”

16 Success !!! hope it Help

I’ll try and I’ll let you know.

Good luck

my programming skills are close to 0.
couldn’t pass step 3 of you explanations…

anyway, thanks a lot!

Hook , don’t touch it if you don’t know what to do there, if you know someone that can do that it a batter choice for you ,
Sorry could help more :+1:

no problem, thanks again for your effort!