Transfer Speed

I have a WD My Book attached via the USB 3.0 port and I’m transferring 2.7TB to a My Cloud. It says that it will take about two days, does that seem like a slow USB transfer speed?

Slow speeds across the USB 3.0 host port on the My Cloud is a well known issue in this subforum. Lots of threads on it. When copying to or from the USB drive attached to or from the My Cloud its best to either use the WD My Cloud Desktop for Windows/Mac, WD My Cloud mobile apps for Android/iOS, the web portal, or log into the My Cloud via SSH and issue the copy command from the SSH command line. The problem appears to stem from using Windows Explorer (and possibly Mac Finder) and the data flowing through the computer rather than between just the My Cloud and its attached USB drive. Toss in copying over WiFi and it gets even slower. See the following thread(s) that cover this copying issue.

I really hope this changes. I’m storing a large TrueCrypt container on an 3.0 external drive plugged into the WDMC. I get 10-15 MB/s when transferring to the container.

Not unless you follow those directions previously posted. WD app or SSH to drive.

What is there to change? Its the nature and limitation of how the hardware and software, including the operating system, work. There are two separate issues at play here. The USB host and client port the My Cloud and the external USB drive use and their data transfer rates. How the copy/move of the data is initiated either by the My Cloud operating system or the computer/mobile device operating system or software/app.

If one is going to use their computer and Windows File Explorer/Mac Finder then its best to be connected to the My Cloud via Ethernet Gigabit networking to get the fastest possible speed as the data flows to and from the USB hard drive through the user’s computer.

One rarely gets the advertised speed from both the USB host/client controllers or from the network interface controllers. Some report getting decent USB copying speeds others do not.

I have a good, fast, wired LAN. I’m using robocopy to transfer files. After using the MyCloud for a few weeks, I’ve decided that the performance of the unit is just terrible in general, not just the USB port.

I regularly transfer videos to the MyCloud drive. I usually get 10-20MB/s, usually closer to 10MB/s. Yet, if I power cycle the Mycloud, and let it sit for a bit after it boots up, I get 20-40MB/s.

When I first got the MyCloud, I was regularly transferring at 70-80MB/s, so it’s performance is actually degrading, even while I still have 1TB of the 3TB left.

Tonight, it’s been horrible. I’m only getting speeds of 4-10MB/s. When I look at the web interface, the content scan still says ‘rebuilding’, 7 hours after I last accessed the drive. I click on details, and everything has a completed checkmark, yet it still says “rebuilding…”

Time for another reboot. :frowning:

While rebooting will some times shake out weird issues, every time one reboots the My Cloud will initiate a rescan of its contents. Which for those who have a lot of data/media on the drive may take considerable time.

It should also be noted that as one copies files to the My Cloud the My Cloud will scan/catalog certain files (media files). If one is copying a lot of media files to the My Cloud it could drag down the unit as it tries to scan/catalog the media.

There are possible ways to disable the media scanning from turning off the DLNA and iTunes media servers to disabling wdmcserverd and wdphotodbmergerd through SSH.

To temporarily disable wdmcserverd and wdphotodbmergerd, issue the following two commands through the SSH terminal:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

To stop the wdmcserverd and wdphotodbmergerd from starting at unit power up or reboot issue the following two commands via SSH.

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

NOTE: Use SSH at your own risk. Performing certain actions or issuing certain commands via SSH can brick the unit. Enable SSH via the Dashboard > Settings section.