Time Machine over SMB

Hi everyone,

to get rid of AFP I tried to setup time machine over SMB according to How To Start Time Machine Backups Over SMB in macOS Sierra 10.12 and Higher. My firmware is 2.31.174

If I try to set the destination with tmutil, I get back the error 45:

sh-3.2# tmutil setdestination ‘smb://xxxx:xxxxx@192.168.x.x/TimeMachineBackup’

Disk does not support Time Machine backups. (error 45)
The backup destination could not be set.

I can mount the share just fine in Mojave.

Anyone tried this out yet and got it working?

I have an EX4100, and I see WD are still selling it and it still claims TimeMachine support.

I’ve been using it on Catalina but since the upgrade it’s become so sloooooow. I had specified the NAS tmutil setdestination as afp://… and it was working on OS versions up to Mojave. Then since Catalina upgrade one backup finishes and then another begins. Permanent disk activity.

Here’s the thing… I notice that if I turn on “Time Machine support” on the General settings page; then go to Network settings and turn off AFP, leaving only SMB active, then when I get back to the General settings page the “Time Machine support” button has been turned off again.

What’s going on? Apple confirm that only SMB is supported, not AFP. Also confirmed by this 2018 article:
https://developer.apple.com/library/archive/releasenotes/NetworkingInternetWeb/Time_Machine_SMB_Spec/index.html

If anyone can shed any light I’d be hugely grateful.

Same problem. WD My Cloud compels the use of AFP which is depreciated. Apple advice is to use SMB which is not possible under OS 5.

Could support please acknowledge and indicate progress on fix or workaround.

The release notes specifically points to a proper TimeMachine over SMB support… it does not work for you?

Thanks for responding. No luck. Have tried via WD GUI to enable/disable time machine and turn off AFP but the the GUI links the AFP ie. turning off AFP turns off the service resulting in backups failing as the MacOS application cannot see the share. The MacOS finder can always see the share but disabling AFP disables the backup process.

What macOS version are you running?

Have you got an existing backup onto the My Cloud or is it a new backup?

Have you tried with a command line?

10.15.7 Catalina

Existing backup which commenced in July 2020 and has incremental backups run without fault which appeared to work via SMB under prior WD OS. This only broke with the OS upgrade.

No attempt at command line.

Hello

To use SMB to backup Time Machine, you can refer to this KB article - https://support-en.wd.com/app/answers/detail/a_id/21360

If you need further assistance, pls contact the WD Support team directly - https://support-en.wd.com/app/chat/chat_launch

Btw, this is the page for OS3 products. If you are having issue with OS5, it’s better to post in the OS5 page - https://community.wd.com/c/OS5/my-cloud-ex-series/255

Thank you for the update.

This is not a reliable nor permanent solution to the problem of configuring permanent SMB Time Machine backups on MacOS widely identified on your support site and other social media with your products.

My Cloud EX2 Ultra OS 5 & Apple OS Big Sur via AFP works fine, the new Apple OS is continuing on the “old” Catalina Time Machine backup.