Is AFP still mandated for TimeMachine?

With OS5 supporting TimeMachine over SMB (and working relatively well despite the no size limit issue), I wondered if one could disable AFP? On the UI it reads that AFP is required for TM.

Could @WDStaff clarify? AFP is deprecated, Netatalk has not been updated for years (since 20th of December 2018), so I guess it would be better to turn it off (CPU and security wise).


1 Like

Great question, why doesn’t anybody answer?

I tried to use my WD MyCloud EX2 Ultra with SMB for Time Machine, but it doesn’t work. If I disable AFP, Time Machine doesn’t find the NAS any more. This seems due to the fact that if I disable AFP to force use of SMB, the MyCloud also disables Time Machine. If I re-enable Time Machine, AFP is reactivated, too.

@WD_Admin please advise.

1 Like

@AustinForest , as you say

OS5 supporting TimeMachine over SMB (and working relatively well despite the no size limit issue)

it seems you found a way to enable TimeMachine over SMB. Can you explain how you use Time machine over SMB?

I’m on Big Sur, which macOS version are you on?


Hello @macuser2387 ,
When setting up a backup in preference system, Big Sur should default to over SMB.
When mouse over the existing TM backup in preference system, you should see an overlay text listing the URL, see below.

1 Like


Thank you very much, @AustinForest , for this extremely useful answer! I wasn’t aware of that feature in Time Machine, and I have been tearing my hair out trying to find out which protocol would be used.

I have two WD MyCloud EX2 Ultra that are both configured for Time Machine backups. Doing what you describe, I discovered that one of it was in fact using SMB, while the other was still using AFP. I have no idea why with two identical devices (same model, same OS version) different network protocols would be chosen.

I was able to fix that by removing the device that used AFP, then reconnecting it from the list of available volumes where it was listed as SMB. I’m curious if that is going to improve the speed of my backups.

Again, thank you very much!