Time Machine backup: how slow is "slow"

I bought a 3TB MyCloud on Saturday. I have two MacBooks, one 3-year-old Pro and one almost new Air, both of them have about 250-300 Gig used out of their half-Terabyte drives in use.

After a false start trying to do the initial backup for both of them at once over Wifi, I’ve set up the Air with a Thunderbolt ether adapter and Wifi disabled, straight into the back of my BT home hub 5 which has also got the MyCloud attached. Green light on the rear connector, and the Mac says it’s doing 1000-base. This has been running since Sunday, and there’s just over 50G backed up so far. So about 15-20Gig per 24-hour day, I make it. At this rate it’ll take another week to do to Air, and then another week or two for the Pro.

This can’t be normal, can it?
Any suggestions? I notice the backup looks to be RAID striped. Would the old incomplete backups be slowing things down?

Thanks in advance for any advice.

Not certain if this applies to your situation:

  • I first set up My Cloud to a 10/100/1000 switch so I could attach the main computers is my household directly
  • I immediately did a firmware upgrade
  • I disable UPnP on my router
  • I disabled all media sharing
  • I disabled cloud access
  • I insured that the first backups and safepoints were scheduled so as not to coincide
  • I connected my wife’s Mac Book Pro - thunderbolt to the switch for the first TimeMachine backup which was relatively fast, all subsequest backups are accomplished via wifi with no input from either me or my wife

I am able to use smartware on me Dell laptop using wifi (additionally this pc is dual boot and Linux als backup up without input.

I don’t think the slowness that you’ve outlined is normal. I suggest deleting the old incomplete backups.

I had a similar problem with a new My Cloud 2TB drive and was getting very frustrated at how slow the Timemachine backup was.

i also had another WD drive, a My Book Studio, attached to the router and I am now convinced it was part of the problem and causing confusion. Here is what I did… first I dissconnected the My Book Studio then

1.Stopped the Timemachine

2.Performed a system restore on the My Cloud drive (this just restores the disk system files to factory settings but does not delete any data files.

  1. Deleted the TimeMachine preference file in Library/Preferences/com.apple.TimeMachine.plist

  2. Restarted my MacBook

  3. Emptied the Trash

6.Logged into the My Cloud, set up user account

7.Opened TimeMachine from System Preferences, turned on backup, selected the My Cloud as the backup disk, logged in as guest, set what items I did not want including in the backup (mainly Applications) and started the back up.

It is now completing the initial bachup at approx 1.3GB per minute which is not too bad. Odviosly simple text files copy faster unlike compressed jpeg or mp3 or video files.

I recoonected the My Book Studio and all running smoothly

Hope this helps others

1 Like

TheRoadToad wrote:

 

2.Performed a system restore on the My Cloud drive (this just restores the disk system files to factory settings but does not delete any data files.

 

 

I was having abysmal performance TimeMachine as well (while direct file copies were fine) and as part of troubleshooting the El Capitan compatibility the Tech had me do a system restore and I saw the same improvement in speed.  From 1GB or less per HOUR to more than 1GB per minute.  In the previous four days it had only managed to backup 300GB and in 4 hrs it finished the remaing 300GB (after the sysem restore).

I can’t explain why - as I was already on the most up to date version of the firmware, but something in the TimeMachine subsystem got fixed when I did the restore

RicardoPas:

I’m having very slow Time Machine backups as well after upgrading to El Capitan. Did you just perform a system restore? Or did you have to do the other steps mentioned by TheRoadToad as well?

Thanks!

I did the system restore and the performance went way up - but it died again a few weeks later.

I’ve given up on the TimeMachine backup and I’m hoping the auto-mount gets worked out so I can use it as a backup drive in CrashPlan or the like, otherwise it’s a brick.

Been through precisely the same problem. Time machine appeared to be working under Yosemite, then asked me to recreate the Time Machine back due to verification challenges. In the mean time upgraded to El Capitan and it has all headed south. Connecting to MyCloud via ethernet for initial backups and file copies. File copy seems to work ok.
Deleted the Time Machine file and the System Restore appeared to work. The next time machine back up rans exceedingly quickly (started at about 1 GB a minute) for the first 140GB out of 500GB then stalled (overnight so not sure when it stalled). I have paused and restarted and once agin the back up speed is incredibly slow - lucky to get to 1 hr per GB. Interestingly ran another System Restore and the speed cam back, but can’t really do that every time it slows done …
Also having problems with the automount which means I can’t use any automatic sync facilities.
Very disappointing !!
Is anything works from Apple or WD to fix this ??

Appear there is no further reply. Update: restored the factory settings. This enable me to get the first update completed - outstanding !! Now 2 weeks later, when it should only be doing incremental backups it has returned to its incredibly slow back up speed. There is something seriously wrong with how the MyCloud is handling the Time Machine write. Although it does some to have occurred in latter versions of Yosemite and ElCapitan has not resolved.
Is this getting assessed, reviewed, fixed ? My investment in the MyCloud is looking increasingly dodgy.

Feedback please.

I’m using a WD MyCloud 3 TB device attached to my gigabit network and a couple of 27" iMacs - one late 2009 running Mavericks and the other late 2015 running El Capitan.

I too suffer from the excruciatingly slow backups with Time Machine where typically the transfer rate is in the low kb/sec.

I have found that if I reboot the MyCloud device from the Dashboard (Utilities > Device Maintenance > Reboot) and then run a backup, at least that initial backup runs at the expected speed with a transfer rate in the Mbs/sec. This is perhaps less drastic than a factory setting restore. I do this each time I want to make sure the backup is completed or if I need to do a restore.

If somebody could explain to me how to write an automated script to do this, I’d be very happy :grinning:

More seriously, this is a long standing and widespread issue and I think it’s deceptive of WD to market the device as being Time Machine compatible yet say it is Apple’s problem when it doesn’t work. If I had known, I would have paid the extra $150 to get a Time Capsule…

Sadly, it is the true, not that makes it any better for you. A bit of research before you bought the WD device, would had giving you plenty of results in which Apple’s time machine is unstable and have nothing to do with WD.

I have a Mac Pro, and using rsync for backups with no issues whatsoever.

I actually believe Apple will never fix it, since people are willing to pay the extra $150 for it.

Maybe you can tell us how you do rsync between the Mac and WD. Obviously that defeats the recover via Time Machine but you can always grab files you need from the rsync.

https://community.wd.com/search?q=rsync%20order:latest

I’ve used a script based on xcopy on my XP machine for years, but have recently switched to FreeFileSync, which is a better tool. Whilst I don’t use the facility, I understand it does support file versioning.

Do a search for “rsync mac backup” or something similar and you will get plenty of options and examples. Rsync is a Linux command, which all OSx are under it.

For those with Windows, I recommend Robocopy. Again, internet is your friend.

@cpt_paranoia, if you are happy with xcopy, no reason to use robocopy. But robocopy is a lot more powerful. It all depends on your requirements.

1 Like

Switch every antivirus off!!!

It worked in my case from bite/min to gbit/min.

Yep rsync is great. But the most important feature of TimeMachine is the ability of going back to retrieve files via the interface. Just got a new MacBook pro running OS Sierra and did a wireless ™ backup of 44GB - took a few hours.