The NAS is unusable

Hi. I had this NAS for a while now. Its been more trouble than help.

I had to send it once to the data recovery place and when it come back, most of my data was corupted. I was patient and did only say thank you for trying. Now, 2 months after, I am having an issue again.

It is very slow. I try to copy 6 Tb foulder and it told me that It will take about 4 days to do it. Then it stoped responding. I stoped the copying and rebooted the device and the same thing again. I am really tired. I like to make you tube video to show you how bad the performance is but i dont thing anyone would care.

San anyone tell me what I can do about this? It is still under the waranty and is the second one that I have with issues.

I am on the phone for 30 minutes now and I am only hearing:

Your call is very important to us, please hold for the next available agent.

Not enough my data being distroyed, now my time.

Hi there, If you are able to access the dashboard, try to restart the unit from the dashboard and also you can try to do a system restore.

Here is a link that will help you with the restore process:

I would like to know the transfer rate you get when transferring your files.


I called and they did a complete reset  of the device.

Still no help.

I was able to go through windows exlprer to one of the directories and try to tranfer the file. The speed was 128Kbs.

The speed was not the only issue. Every few seconds would prompt and tell me to check the connection to the device.

I have another my cloud that is 4Tb. This one dont even start anymore and is almost new. Another my passport 2Tb failed few months ago. Its crazy what is hapening. All because the WD devices. I should have gone for something else. But then I am stuck with all this devices that are useless and and i cant return. What about the data that I have worked all my life?