I'm done with this device

So I’ve had the MyCloud ex4 for almost a year and I’ve reached the point where I’m just going to cut my loses and go with another NAS product. 

I have mine running with WD Reds and although the hard drives perform fantastically (never had a WD hard drive fail), I’m not impressed with this product in the slightest. Right out of the box I notice performance is just abysmal, you log into the dashboard and you can see what little amount of RAM it has is just getting smashed. Not being a person who gives up straight away I jump on to the forums and have tried many of the suggestions and tweaks discussed here (nothing bad to say about the community here btw, thank you for helping others get the most out of this product) but have just accepted the fact that this device is extremely underpowered. I mean I’ve done all the ssh in and disable mcserver stuff, turned off just about everything on this box until it’s just basically there to share files over the local network. At this point it’s just on the edge of being tolerable at best (but this thing is meant to be a cloud device and has the firmware that allows it to do so much more, but how could this thing possibly do that with what little resources it has…).  I’ve spent countless hours messing with it, messing with my router and anything I can possibly think of. Today I can’t get to the dashboard so I did the pin reset on the back. Got dashboard back and now it keeps freezing and becoming unresponsive. 

This time I’m not putting in the time to figure out what’s wrong with it. I shouldn’t have had to do this much fiddling in the first place. I’m not even going to burden another person by selling this to anyone. Time to go check out some Synology reviews. 


I totally agree with your assesment of this device.  

Over sold and under delivered BIG time. 

I regreat purchasing this underpowered product I wish I could turn back the clock and pay more money for a vastly superior device.  

Even more of a dissapointment is WD now selling the EX4100 which looks to have the chops to do what the EX4 was sold to us as…a personal cloud.  To me, that’s just a slap in the face.  

I have to agree with guyver_dio and sgallant04 somewhat.Performance is not too good. In fact its very poor IMHO. My main grouse is the the amount of time it takes to transfer files from PC. I have tried so many tweaks etc but to no avail. Maybe if it was kitted out with 2GB RAM it would be a better unit. I have 2 gigabyte ethernet connections and the link Aggregation set to Round Robin as suggested in another post.
I regularly need to transfer around 1.5GB of small rars and it can take around 8 hours speeds in the kb/s range…CRAZY. and after they have been transferred the activity HD lights flash for anything up to and more than 12 hours. I do get slightly Higher speeds if i transfer the parent folder instead but when i separate them out on EX4 im back to the extremely slow speeds. Maybe im missing something somewhere or NOT!!

The same opinion.

I had problem after problem and finally sent it back (under warranty). This culminated in an apparent hard drive error (red light on disk #1). They sent me a new one and have been trouble free since then. Now it is important to note the replacement had the old GUI (the charcoal gray screen) not the new one. I have since kept the auto-update turned off. I think they really stepped in it with the super-duper new look and features.

Hmm, this is odd. I actually get a very fast speed even over wireless to the router that this device is connected to. I get around 90MB a second at the minimum. Also, make sure your router supports link aggregation (most small consumer routers do not support advanced options like this, might need a separate hub). If it does not support link aggregation you will notice a massive drop in speed when using multiple ethernet connections. I did the same thing as you, didnt realize my fancy router didnt support it until i read further in documentation. I was looking for the MAX speed the unit was supposed to produce but using link aggregation actually made my speed go down to the low kilobytes. Since I switched it back to single ethernet it works fine, 90MBs easy and the slow speed was my own fault with poor network configuration.