Support NFS ver 3 and file locking


#1

I have been using My Cloud 4TB drive as local file server for few years and it was working great. I purchased a My Cloud EX2 Ultra with 2x2TB drives last week. Both drives are on an isolated LAN with no access to internet.

I tried to use the EX2 drives same way as my old drive but keep getting timeout errors. Found out that the software I am using requires NFS version 3 and file locking to be enabled. The timeout I am getting is because of file locking is not working in my EX2 drives.

I have Share to Public = ‘ON’, Oplocks = ‘ON’, NFS share access = ‘ON’ and allow read/write from any host.

The default export options being used:
(rw,insecure,root_squash,all_squash,no_subtree_check,insecure_locks,anonuid=501,anongid=1000,sec=sys,rw,insecure,root_squash,all_squash)

This is the export options in my old cloud drive, which is working:
(rw,no_root_squash,sync,no_subtree_check,insecure,anonuid=65534,anongid=65534)

Is there a way to change the NFS export options?
Does EX2 Ultra support NFS version 3?
Is there more configuration I need to do on the EX2 drive? I have only done configuration through the GUI so far.

I don’t want to send this drive back. Any pointers/guidance would be much appreciated.

Regards,
-Johnny


#2

Hi,

You can contact WD support, they will rectify your issue. or you can check the link below mentioned-


#3

Hi,

The instructions are exactly what I did and that did not help.

I updated the EX2 Ultra drive firmware to 2.31.163 today and it seems to resolve the issue. Well, I will give it a few more days to see if I will get the locking error again.

Does anyone know how to change the NFS export option on the MyCloud EX2 Ultra drive?
It seems to have hardcoded to (rw,all_squash,sync,no_wdelay,insecure_locks,insecure,no_subtree_check,anonuid=501,anongid=1000) from output of ‘exportfs -v’.

I already have a user with UID=501 and GID=1000 on my local system. And this user now owns all files on the NFS share. I need to change this behaviour!

I want to change the exports options to ‘anonuid=65534,anongid=65534’ which is the default ‘Anonymous NFS User’ on Linux. But every time I reboot the drive, the options in /etc/exports file gets reverted back to the defaults.

I only want to change the anonuid and anongid settings in the export options. How can I make the change persistent across reboot?

Could someone help?

Thanks.
-Johnny