Stuttering Video

I have a serious issue with video playback - it stutters. I’ve tried connecting to my TV with wifi, and with a homeplug. It stutters with both. I am not going to run an RJ45 cable from the My Cloud to the TV, and I want to be able to watch video on any device I connect to my network.

Color movies (not even Blu Ray) have a tougher time than BW movies, so it appears to be bandwidth related. BUT, I might be the only device on the network, and it still stutters. I have even tried being in the same room with the My Cloud, to no benefit. I have all my movies in MP4 format, so that shouldn’t be a problem. My network broadcasts in B/G/N. My Blu Ray player is a Panasonic

I can change the encoding of the movies if I have to. Are there any solutions to this issue? It’s been discussed by many, but no solutions. I’ve also tried “casting” videos to my Chromecast, via my Android phone, but the problem gets worse. I’d like to use my iPad, too, but first things first. Any ideas?

I’d first see if it’s WiFi or network related.

So, as a temporary test measure, connect your TV to your router by cat5e cable, and remove all other connections to the router other than the mycloud. Turn off WiFi on the router.
Now see if it stutters.
Turn on router WiFi and do the stutter test.
Reconnect devices one-by-one to the router, checking stuttering each time.

If you get stuttering right from the first test, there’s a problem with data transfer between cloud, router and TV. Check all connections/cables.

If reconnecting WiFi/devices gives the first stutter, then it’s likely something is jabbering on your network, and your router can’t cope.

If you get no stuttering, then the problem is WiFi. Use a WiFi diagnostic app to see what’s going on; you could have a noisy or congested environment.

You don’t say what router or WiFi you have, so I’m assuming it’s at least 100Mb, and the TV is WiFi-n.

The router is a Motorola 2247 N8 B gateway, which is only rated (per their manual) as only 100 mbs. Is that too slow? Also, do you recommend a Wi-Fi diag tool? I’ll look around, anyway.

Here’s something that might be interesting: the audio is fine, but the video has jerks every few seconds. I’ll try your other suggestions in the morning.

Well, it gets weirder. I plugged my router, and my 3TB My Cloud directly in to my Blu Ray player, which has the DLNA software/firmware in it. After everything came up, I fired up my DVD player, and went to DLNA, and the to MC. For whatever reason, the MC didn’t/Couldn’t see the videos folder, only pictures, and music folders. So, I tried both of them, but the response for both was there was nothing in either folder. That’s incorrect, so I backed out of the whole thing, and tried again. This time it saw no folders at all. The MC front panel LED was blue when I tried, so it was fully booted up.

Now, it’s back in place, and everything is back to “normal”.

Well, it gets weirder. I plugged my router, and my 3TB My Cloud directly in to my Blu Ray player

Do you mean you plugged your MyCloud and your BluRay player directly into your router? Your router is the central connection in your network.

When you re-boot the MyCloud, the Twonky media server will rebuild its database; this takes a few minutes, so it’s possible it hadn’t rebuilt the database when you tried to access it.

Yes, I connected the My Cloud, and the Router, directly into the Blu Ray player, which in turn is connected to the TV.

When I saw a blue LED on the front panel of the MC, I assumed it was all ready to go. Perhaps it wasn’t. How long should it take? I have 130 Movies on it, and 50K(?) m4a music files.

Yes, I connected the My Cloud, and the Router, directly into the Blu Ray player, which in turn is connected to the TV.

Sorry, but there’s a subtle but important difference between what you’re saying, and what I’m asking.

You’re saying that you plugged both the router and the MyCloud into the bluray player. I’m not sure how this is possible unless your bluray player has two RJ45 Ethernet ports.

You should have an Ethernet cable from MyCloud to router, and another Ethernet cable from bluray to router.

You can find out the status of twonky’s media scan by opening the twonky ui in a web browser; it’s port 9000 of your MyCloud’s IP address, e.g. or

Go to the ‘Status’ page.

Exactly what I did. I couldn’t check the media scan because I had it disconnected from the phone line (DSL internet access).

You don’t need DSL access (the outside world) because you’re working entirely local to your network.
You will need to connect a computer to the router though, so you can access the Twonky UI…

Twonky can have trouble finding media sometimes, due to the way it conflicts with the MyCloud. I’ve seen it seemingly add media to its database, only for it to delete almost everything again when it finishes. But that’s incidental to the stuttering issue…

If you’re getting 20Mbps over your local network, it really ought to be enough for video.

If the MyCloud is throttling the rate it can stream video to your network, that might cause the stuttering. If the MyCloud is doing its media thumbnailing, that gobbles CPU, and might prevent it delivering the required video data rate. It shouldn’t, if implemented properly so it drops to a background task but… Again, the answer might be to wait until the Dashboard says it’s complete.

I can stream video by WiFi to a little Android media box connected to the TV, without getting stuttering, most of the time, but I have noticed things like Facebook deciding they need network data causes the odd pause.

The other thing to think about is whether there’s a basic problem with your MyCloud’s Ethernet port: what sort of copy speeds to go get from MyCloud to computer: try a large video file, for instance.

Have you tested what @cpt_paranoia has suggested with a cat5e? That’s the best bet to know if either router or TV or MyCloud is abnormal.

100Mbps N rated wifi router or homeplug shouldn’t have stuttering with your normal vids unless your vids have very high bitrate or your network is congested heavily. I can stream 10GB 1080p from home to another TV located at someone else’s place without stuttering, just few seconds initial buffers (MyCloud->Internet->Wifi->SmartPhone->Cast->TV). This also works from a 4G network so I don’t think your stuttering issue is solely related to MyCloud.

To test your wifi, there’s several apps on mobile/pc. I’m using mobile Wifi Analyzer to check for congested channels. My area both 2.4GHz and 5GHz are like hotcakes overlapping. If you’re living around one like mine, choose the least overlapping channel. Note that other non-ssid broadcasting devices could also be the culprit i.e. cordless phones and baby monitors. Replace those with 1.9GHz or 900MHz if possible (if they belong to your neighbours, get them a new one :stuck_out_tongue: ).

I just copied one of my movies off the MC, and onto a flash drive. It still stutters a bit, but not nearly as bad as of the MC. This leads me conclude 2 things. There is a bandwidth issue between the MC, and the TV (though a big issue), and ALL 130+ movies I put on the MC have been converted such that they all incorporate the same stutter, however, it’s not on BW movies (Dracula).

I used Freemake to convert the mmovies from DVD to mP4. Was that the wrong program?

Copy a couple of movies to your computer’s local hard drive and play them from the hard drive to see if there is stuttering/corruption. If so then the problem lies with the program used to create the video.

If there isn’t any stuttering or corruption from the local hard drive that points to being a possible bandwidth issue or possibly a Media Receiver Type error with Twonky on the My Cloud.

I use the popular and free program called Handbrake to convert movies (or DVD’s that have been ripped). No problems streaming that content for the most part from a My Cloud. I do however have my streaming client devices (Roku’s) hard wired rather than WiFi.

If there isn’t any stuttering or corruption from the local hard drive that points to being a possible bandwidth issue or possibly a Media Receiver Type error with Twonky on the My Cloud.

Or a problem with the OpenELEC renderer.

I have Handbrake, too. I don’t remember how many movies I converted with it, but not many.

What settings do you use for Handbrake? My Panasonic DVD player can’t handle m4v files. It’ll do mp4 files, though.

Have you tried renaming the files to mp4 to see if they’ll play? m4v is basically mp4 with optional DRM support.

I did try that. The WD (or rather, Twonky) coughed up a hairball, and wouldn’t even try to play them. It said there was an “error” trying to play the file.

I changed my password everywhere to ‘incorrect.’ That way when I forget it, it always reminds me, ‘Your password is incorrect.’

Thanks for telling us your password…

When you say Twonky gave an error, were you using Twonky’s media browser, or accessing the twonky server via some other client app?

I was using both the app Twonky Beam, the IP - directly via the dashboard

Our toaster has two settings: too soon or too late. -