Stuttering playback with stock firmware and local files

After hearing rave reviews of the WDTV Live, I snagged one for myself. Unfortunately I’m really not having a great experience. My main scenario is playing BluRay MKVs and ISOs. At least 50% (probably more like 75%) of the time, I’ll get audio and video stuttering. Sometimes it happens right away at the beginning and sometimes it will happen part way through the movie. I’ve completely removed network issues from the scenario by playing off a USB hard drive and a USB thumbstick. I’ve found that if a file experiences stuttering, it will happen regardless of whether I’m playing it over the network, from the USB hard drive or from the USB thumbstick. I had this when I pulled it out of the box and after the latest firmware update. And when I say stuttering, I mean it’s completely unwatchable. The sound drops out and I get maybe 1FPS or it will just hang (though that is more rare.) Did I get a bad unit? Any ideas for me?

I am having the same issue playing video files, and I’m wondering if mine is caused by network congestion.  I haven’t tried playing a file directly from a usb drive - may try that tonight.  Music files play just fine.  I have been tempted after reading some of the other posts on here to attempt a firmware rollback, but I’m afraid of messing up my Netflix module.  It’s a shame, because I really like this device.  I keep hoping a new firmware update will solve some of the issues if there ever is one.

Hi All,

I am also having what seem to be the same problems as you are BWMartens.

I have recently purchased a WD TV Live (the one with the built-in wireless). I also have an older model WD TV (without built-in wireless).

The problem I am having with the new WD TV Live is that I am getting a stuttering effect when I playback RIPs of Blu-Ray movies.

These play perfectly fine on the older WD TV.

All other movies (.ISO from DVD) play perfectly fine on both media players.

I am playing the movies (.ISO) directly from a USB attached hard drive.

The firmware on the new WD TV Live is v1.07.18. I can’t seem to roll back any further (as I saw suggested elsewhere).

Has anybody else come across this issue? If so, have you been able to rectify it?

Any advice would be appreciated.



Hi All,

I have been in contact with WD support regarding the stuttering effect on BluRay .ISO movies, and I have a reply.

After many emails back and forth, I have been told that the WDTV Live Streaming does not support the VC-1 codec, and this is the codec used for my BluRay .ISO movies.

This codec is supported in previous versions of the WDTV.

I have made it very clear to WD that this is not satisfactory, as I believe that a product like this should perform AT LEAST as well as a product that it supersedes.

WD Support tell me that they have passed my “suggestion” on to their development team.

I am not sure there will ever be a solution.

It’s a shame because I mostly like this product.  ;-(


Thanks for the update. I was able to play from a usb thumbdrive to confirm that my problem was network congestion.

I have the exact same problem while playing .mp4 files with .h264 codec, or sometimes .avi even from a USB hard drive. The only files that plays flawlesly are .MKV, no mather what codec it uses.

Any solutions so far?

Do you have any problem with .mpg files?  What about .iso’s?

I think there are quite a few different problems going on in this thread. Here’s an update on my problem which caused me to start this thread originally.

  1. I went through a long thread with tech support trying to reset the box, try it with different TVs, different HDMI cable lengths, etc. Nothing helped.
  2.  I tried rolling back through the previous firmwares. You can find those instructions here: Nothing helped.
  3. I RMA’d the device. That didn’t help either.

I’m basically giving up and encoding files differently to formats that I know work. It’s frustrating, but I’ve spent so many nights on this that I’m sick of it and some extra CPU cycles are a fine tradeoff for now. After so many glowing reviews, it’s frustrating to be one of the few people who can’t make this work.