Streaming content to iphone

Hi everyone, 

I bought a 2tb MyCloud the other day and am pretty impressed with it to be honest. The only problem I’m having is streaming content to my iPhone.

I’ve installed the WD app, connected MyCloud so I can see all my files and folders, but when I select a video file to view, I get  a picture of a man with question marks all around him, I presume this is some kind of error? 

Am I missing something here, I can see all my files but can’t open any of them, do I need to enable something else?

It shows “confused man” if the app doesn’t know what kind of file it is. If it is a video file, it must be Apple compatible format M4V, MP4, or AVI file.

Ok, I’ve selected an avi file but still get the “confused man” icon. When I get rid of that though it looks like it was trying to download the file not stream it & by getting rid of the confused man it cancelled the download.

Im sure I’m missing something I just don’t know what!

I was experiencing the same issue with MKV files. You need to install VLC player on your iPhone and or iPad and stream to that app on your home network. If your outside your home network you will need to turn on FTP on the My Cloud and port forwarding on your router, then you will be able to stream outside of your network with VLC player without the file downloading to the device.

1 Like

An AVI file is just a ‘container’ that can hold many different encodings like AVC, H.264, etc. Not only does the file type need to be compatible (AVI, MP4, MKV) but the encoding needs to be supported. I found an apple discussion that talks about some of the encoding that iPhone5 supports and it may help you. You will most likely need to find a video converter that can encode the files to a compatible format.

In addition to MyCloud 2 and 3TB drives, I have a Synology DS414.  I’m experimenting with streaming video remotely initially to my iPhone and then to other devices.  I have a test *.avi movie which plays fine at home to my WDTVLive devices no matter if I stream from MyCloud or the Synology.  However, when I stream from either NAS within or outside of my network to my iPhone all works well when streaming from the DS414 (I have VLC installed on my iPhone which gets invoked immediately) but when I stream the same file from my 2TB MyCloud to my iPhone, I get the confused man.  Same file, same mobile device.  The only difference is the drive system that I stream from.  One works for this application, the other doesn’t.  I don’t see a WD configuration option which will fix this, leading me to believe its in the implementation for streaming coded in the firmware.  I am using the MyCloud phone app and the Synology DS Files phone app and the latest firmware on all drives.

I’m sharing not to bash MyClouds but to offer a comparision which might be helpful in resolving this issue.  I like my Clouds and use them primarily for back-ups and streaming videos within my home network - which works just fine. 

My guess is that the my cloud app itself doesn’t recognize AVI as a valid file extension. I highly doubt that the NAS is looking inside to see if the contents are apple compatible…

I’d bet if you try VLC directly (via FTP) to the cloud, it’d work the same as the other NAS.

mycloud app is very basic and does not support avi. Try ftp and from another app that supoprts avi and ti will work. they should really add an option to “open in” where we can tell it to open the file in another application.

Actually they have open in, just noticed and I can open the file in VLC.

An “open in” function in the phone app?  Where is it?  I don’t see it.

open mycloud and connect to your drive, select a file, and an option will appear on top right hand corner ( like a square with an arrow pointing upward). Click on that and it will give you options to open in another application if ti cannot play the file (the option is “open in”).

On my iPhone app the only option I see is “Email as link”.  I ran a simple test this morning.  When I select a file using my My Cloud app I get an immediate warning of Data Usage (I have to go 3G from my work because access is otherwise blocked by our firewall when using wifi). After clicking Continue I get the confused man :)  and the small square at the top right.  Clicking on that square only gives me the option to Email as Link.

it only gives this option if it can play the file. If it does not, then it shows: email, email as link, open in.  That is how I use to play in VLC or open a document in an app. I just tried again on my Iphone and Ipad.

my bad :frowning: , on the Iphone I was connected to DropBox where it works but not on mycloud. Works on Ipad though.

Iphone 5 seems ot show the option in local network, but not outside.