Still no joy with iTunes 10.5?

I have updated to firmware: MyBookLive 02.10.09-124 : Core F/W per knowledgebase article.

I’ve set up Public media share, but Music is not showing up in iTunes 10.5.3

(see screenshots below)… any ideas appreciated…Thanks!

my book share.png

itunes share.png

We have to wait for a moderator to approve your images before anyone can see them.

Other than that, make sure you have iTunes Server ENABLED, and you might try to “Rescan” it, using the button on the iTunes section of the Web UI.

Thanks. Yes iTunes media server is enabled and rescanned. Mac rebooted.

Everything else on the MBL seems to work ok:

  • wireless Time Machine

  • remote WD2Go & photos

  • private shares

If I double-click on any of the media files, iTunes opens and plays them fine.

Not sure what else to check/try?

itunes server.png

I had a similar problem with Itunes.Open Itunes, click on the device, then one by one make sure that synch is enabled

(music, movies, etc…) 

Not sure of this also, but you might need to authorize the MBL ? 

iTunes Server isn’t used to sync, so this is a different thing altogether.   There’s also no mechanism to authorize an iTunes Server.

Still need to wait until a moderator approves the images to see what you’ve posted.

You could also post them to imageshack or something to be faster…

OK, I’ve posted screenshots to imageshack…

screenshots

URL= [http://imageshack.us/photo/my-images/837/itunesserver.png/][/URL]
URL= [http://imageshack.us/photo/my-images/810/mybookshare.png/][/URL]
URL= [http://imageshack.us/photo/my-images/543/itunesshare.png/][/URL]

Is your iTunes FILE storage on the MBL itself?   In your first pick, you’re showing a listing of files, but the source is blurred out.

Here’s another thing you can try.

SSH into the MBL, and go to this folder:

/CacheVolume/forked-daapd

You should see a file in there named “songs3.db”

Is it there?   Is the date somewhat current?  

execute the command

“strings songs3.db | more”

does it list (if somewhat cryptically) your music?

iTunes storage is on my Mac drive. The Finder window displayed is from the MBL Public folder (mounted as Esquimalt).

I can play these tunes thru my iPhone from the WD2Go app, so I know they are properly stored on the MBL.

If I click on one of them (the MP3 file) which is not in my iTunes library, iTunes opens and plays it fine (and all the other songs are also in my Mac iTunes Library).

I put another post in probably as you were typing your reply.  Scroll up to see it.

Thanks tony… for the ssh suggestion.

I haven’t tried that yet… I bought the MBL as a plug-and-play service - I really didn’t want to have to delve into the OS. The iTunes integration is not a big req’t for me right now.

There are some other strange things going on with my MBL though that give me pause on relying on it (inconsistent account authentication with WD2go, TimeMachine backups becoming inaccessible…).

I’ll just continue to ‘play’ with it when I have the time and inclination. Overall the MBL is a good concept but it could benefit from more extensive QA/testing.

dendro wrote:

Thanks tony… for the ssh suggestion.

I haven’t tried that yet… I bought the MBL as a plug-and-play service - I really didn’t want to have to delve into the OS.

No doubt…  nor should you have to.

Just was hoping to narrow it down to a specific cause… :slight_smile:

Feel free, of course, to come back into this thread if you’re feeling adventurous later.

I thought that I would add that after upgrading to the latest firmware i still dont have music or videos showing up in itunes. A response from Western Digital made it sound like the firmware was only for music and there is no fix for videos. Can anyone confirm this?

Here is what I had to do in order to fix the iTunes problem.

Had just purchased my 2TB. After initial setup, which included setting up shares, access to WD Photos and WD 2go Pro, and dragging about 40 GB  of MP3’s,  photos and videos to the appropriate public share folders, the drive phoned home to WD in order to perform a firmware update (latest and greatest). All was well until I tried to set-up the drive with iTunes.

As A LOT of people have been discovering, NO JOY.  Drive was recognized, but the songs would not populate. I spent nearly an hour with a very helpful outsourced support person. I’ll give him this, he tried, given what little resources WD had supplied him. But the fact of the matter is, he hinted that the update to -124(?) was the beginning of this problem.  I’m sure WD is scrambling to resolve this and wishes to remain quiet until then.

Now, I’m no Steve Wosniak, but I’ve been involved with computers since the first Apple fell out of the tree, so I consider my knowledge base to be above average. I’m currently a PC person.

I finally had to return the drive to factory settings, run the complete set-up again and, voila! iTunes immediately began populating. Luckily, I only had a somewhat small amount of data to lose, so I chose NOT to perform a backup prior to this. And, I certainly would not have saved and reused any configuration settings for the drive as I feel this would have brought the problem back.

Hope this works for someone.:angry:

Video via iTunes after version 10.3 is no longer supported.