Solid green light - MBL not found on network

When I plug in the MBL it cycles from blue to a solid green. I can even pull the ethernet cable out and it will stay solid green. I have tried different ports on router as well as different ethernet cables and always the same. Any options to connect? I am using windows 10. I just want to get my data off of it. Thanks!

I just plugged the ethernet cable directly into my computer and I get this message

"Currently, this hardware device is not connected to the computer. (Code 45)

To fix this problem, reconnect this hardware device to the computer."

I don’t think you can connect your MBL directly to your computer using the Ethernet cable. Your computer and your MBL need their own, separate IP addresses which a router or switch connected to a router will issue. If you have a green light, that’s promising though.

Have you tried the WD Discovery Tool, it’s supposed to find your MBL on your local network

Hi ! By now you probably already have a solution. If not, try to connect the MyBookLive directly to your computer via ethernet, then using your browser, type in “http://www.mybooklive/” in the address bar of the browser. This may open up the MBL Dashboard. If not, look at the bottom left corner of the browser window, there may be an ethernet address <192.168. …etc.>)in the margin. Write down this address then disconnect your MBL’s ethernet cable from you computer and reconnect it to your router such that the MBL is connected to router. Now type this ethernet address into the adress bar of your browser. Hit return and hopefully it should open the MBL Dashboard. Once there you can reset your preferences, system, factory restore, etc. and run some diagnostics. After almost 6 months of not being able to use this drive, and ready to thrash it, I’m now on the verge of bringing it back to daily use, thanks to the help of this WD support community.