Smb2 Settings My book live?

My company is changing over to windows 10, meaning we will be losing SMB1, which in turn means losing our mybook live nas drives. Performing a workaround on windows 10 is not an option. How do I switch our my book lives over to SMB2 or above? We have a buffalo drive which is just a simple click on the dashboard to SMB2 and I believe My Cloud nas drives are the same but have no idea how to do this on a MyBook or MyBook duo?? Is it simply that the MyBook’s are too old to support SMB2 or above?

I have no problem at all using MyBookLive with Win10. Are you at a current firmware level? I have 02.43.10-048.

Problem is our IT dept have switched off Smb1 settings with the use of win10 and whilst it’s easy to switch our buffalo to smb2 setting the same case doesn’t seem to be the same for our mybook live nas drives

From a Wireshark packet trace it appears I’m using SMB2 to talk with MBL. (t least I saw an SMB2 query go by). I’ll disable SMB1 support on Windows and see what happens.

I just disabled “SMB 1.0/CIFS File Sharing Support” and rebooted. I can still MBL Public share as a mapped drive on Windows 10. Issuing the
“Get-SmbConnection -server MyBookLive | fl” shell command shows

ShareName : Public
UserName : PUGET-116877\Patrick
Credential : PUGET-116877\Patrick
Dialect : 2.0.2
NumOpens : 1

Looks like I’m using SMB 2.0.2. Is it possible your your IT department did something else to block the connection?

Hiya pokeefe, thank you for your efforts. I wouldn’t have thought so and like I said on our buffalo drive you can manually change the setting to use SMB2 and works ok. So does that mean the MBL and the duo’s do support smb2 and above and automatically switches settings themselves? I would have thought there would be a manual setting on the dashboard but there isn’t. I’m able to use the commands
sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

to disable SMB2 and force the machine to use SMB1 but if IT finds out we will be shot!! Will try to find out if there have been any other changes they have made which would stop the MLB’s automatically switching over if that is indeed the case they are supposed to. Just to clarify, my own IT skills are fair to middling.

As far as I’m aware all IT have done is switched SMB1 off and delivered it via group policy to our windows 10 builds, don’t think they have done anything other than that.

I could find no option on MBL. I suspect it uses either SMB 1 or 2 depending on the protocol handshake it receives. (That is a guess based on absolutely nothing.)

Are you sure your problem is a result of SMB 1 being disabled on Windows? What are the symptoms?

Yeah starting to suspect that there is something that they have/haven’t switched on. They have never been happy with our use of nas’s and it’s hard to get them to assist. I will bring it up at the next IT meeting I have with them and see if there is something that can be done.In the meantime can you tell me how I run that shell command so I can try and find out more information on how they are operating on our network Is that something that is run from a program like Visual studio?

In the Start menu expand “Windows PowerShell”. One of the options is “Windows PowerShell”. The command I mentioned earlier has to be run from an elevated command so right click on “Windows PowerShell” and select “Run as Administrator”.

Interesting, get 2.02 on my home one as well. Hopefully I’ll have the admin rights at work to run a test on those. Thanks!!

In a Western Digital Community posting from September 27, 2017, “pokeefe” indicates that his “MyBookLive” has somehow switched to SMB 2.0.2 (They are called Dialects). (I hope he changed his credentials after this posting. :grinning: )

I verified these results on my own machine using Windows Powershell and entering:
“Get-SmbConnection -server MyBookLive | fl”
I had gone back through Windows Features and re-activated SMBv1 prior to performing the action above.

See my problems at:

I think that “somehow switched” is just MBL using the highest dialect it supports. Or maybe Windows selecting the highest level dialect supported by the NAS. I’ve since then replaced the MBL with a MyCloud and that connection automatically is using 3.1.1.

No need to change my credentials. That is a public share with no password (and accessible only on my LAN. And in any case, the Get-SmbConnection display seems to local_username / remote_username pair when displaying a connection to a private share - no password. I think that may be the key Windows uses for accessing the password. (That’s just a guess.)

Thanks for your quick response. I just wanted to clarify a few things. When using your My Cloud, do you see the 3.1.1 dialect being shown in the Get-SmbConnection display? Also, if you look back at the SMB settings of Windows Features, is that also showing v3.1.1, or does it still indicate v1.0?


The 3.1.1 is from the Get-SmbConnection display. I disabled v1support in Windows long ago.

Just wondering… Now that you are using a My Cloud, do you see a check mark for “SMB Direct” in the Windows Features list?

I don’t know if you are asking me or the thread starter. If me, I feel bad about hijacking this thread. I had never heard of “SMB Direct” until you asked and I don’t really understand a thing I’ve just read. I’m certain my on-board NIC is not “RDMA ready” so I can’t use SMB Direct. So the answer to your question is “No, I don’t have SMB Direct enabled”. But how does this related to the original topic of the thread?

And speaking of the original topic of the thread, … . Is Shadowfire still watching this thread? If so, did you ever get your problem solved?

Is it possible to update the MBL to SMB3? I’m trying to connect my Chromebook to my MBL and it appears Chrome OS requires SMB3