Smartware Drive Unlock... does nothing

Hello all. Looking for a solution to a bizarre problem that’s come about with my 1TB WD External Drive. The problem consists of me typing in my password when prompted to do so in order to unlock my drive, however when I click unlock, it does nothing! I’ve tried quite a few times and still get nothing. Upon closing the window and re-opening the drive unlock option, the screen tells me that my drive “isn’t” locked, and that it should be good to go. Unfortunately, I can’t seem to find it as it wont show up on my computer. So, in short, I try to unlock the drive, it does nothing, blinks once or twice if anything, then when I try to re-open the unlock screen, it says the drive is no longer locked. That sounds great on paper but now I can’t seem to find the drive anywhere. I have tried to get it working on another computer as well. I’ve had problems with this drive in the past (extreme lag, cyclic redundancy issues) and really just want to get it up and running again. I ran a chkdsk on it this morning, that seemed to clear up alot of the issues I was having. But now, upon reboot of the system, it doesn’t seem to want to show up. Any help would be appreciated. As always, like everyone else, very important files on the drive. Wouldn’t mind getting my 800gb of data saved. Thanks

Just formatted the drive after typing in an incorrect password 5 times. Worst came to worst and I decided to do that. And as expected, it still doesn’t work. Just wanted to voice how disappointed I am with WD and their products. I really can’t see how anyone makes it by with these products. Especially seeing how many issues are clearly happening.

Anyways, seems like the drive is a vegetable now. When I try to play around with it in disk management it keeps telling me there’s some cyclic redundancy issue or that I don’t have proper permissions. Bizarre product. Has given me nothing but grief and wasted time.

Hello, one more thing you can try is to download DLG and write zeros to the hard drive. Check the link below for the steps.