Slow write Speed on Shuttle 32TB Thunderbolt 3 Win10


#1

Hi,

we just got a brand new 32TB G-Speed Shuttle with Thunderbolt 3. After setting up the drives as a fresh RAID 5 and reformatting via the G-Speed Software Utility to NTFS, the drive was “synchronizing” for a really long time. After letting it sit and finish synchronizing I started doing some test and weirdly I only get about 90MB/s write speed, although I’m getting good read speeds at around 650MB/s.
I get those results when I try to plain copy files from the internal SSD or HDD and also with the AJA System Test App.

Before ever connecting the Shuttle to the machine, I made sure to download the Windows TB3 drivers that are provided via the G-technology homepage.
There are no background activities running and the G-Speed Software Utility shows no warnings whatsoever.

Here’s the stats from the AJA test run:

AJA System Performance Tester 2.1 - starting Fri Jan 25 2019 15:12:03

NetBIOS name : MININT-R09SOML
DNS hostname : MININT-R09SOML
DNS domain :
DNS fully-qualified : MININT-R09SOML
Physical NetBIOS : MININT-R09SOML
Phys DNS hostname : MININT-R09SOML
Phys DNS domain :
Phys DNS fully-qualified : MININT-R09SOML
Host OS : Windows 8
Host Processor : Intel® Core™ i7-8750H CPU @ 2.20GHz
Number of Processors : 12
Type of Processor : 8664
Page size : 4096
Physical Memory Total : 32660 MB
Physical Memory Free : 28531 MB
Memory Used : 12%
Paging File Total : 37780 MB
Paging File Free : 30645 MB
Virtual Memory Total : 134217727 MB
Virtual Memory Free : 134213481 MB

Number of AJA Devices: 0

Disk Test
Resolution: UltraHD
File Size : 4 GB
Codec : XAVC-4K
Drive : F:/
Cache : Disabled
Video file: Movie

Disk Write Test
Number of frames = 3404
Write rate = 69 frames/second
Write rate = 83 MB/second
Minimum rate = 15 MB/Sec
Maximum rate = 296 MB/Sec

Disk Read Test
Number of frames = 3404
Write rate = 505 frames/second
Write rate = 607 MB/second
Minimum rate = 21 MB/Sec
Maximum rate = 1326 MB/Sec

Any help would be greatly appreciated!

Thanks in advance!
Johannes


#2

Make sure you have the most up to date Intel Thunderbolt drivers for your motherboard, also within our G-Speed Software Utility in the file menu check for updates, this can apply updates to firmware and software that might be able to help.

Another thing to try is that you tried using it while it was synchronizing and it could have corrupted. You might need to delete the RAID and start it over from scratch and not use it until it completes.


#3

Thanks for your reply.

I tried updating Thunderbolt Drivers, but they are up to date.
I’m pretty confident, that the slow write speeds aren’t because of how the Shuttle synchronized.
I since tried using a single G-Drive with TB3 and got similar results: decent read speeds and terrible write speeds. When I connect the G-Drive via USB however, everything seems fine.
Could it be an issue with G-Technologies Thunderbolt3 for Windows drivers? Are there any updated versions of their drivers coming?

Thanks!
Johannes


#4

Oh, I also was able to try the Shuttle on a different windows machine with TB3 and got similar results. Read speads of around 600MB/s and write speeds of about 100MB/s, which is still too slow for a Raid 5 over TB3, right?
The TB3 controller on the other windows machine is not the same one as in my machine btw…


#5

We’ve yet to see issues relating to TB and Windows causing performance issues with our devices.

You are sure you have Windows 10 GSU & Windows TB3 driver installed?

In your device manager do you have any remaining ! or ? If you can I would suggest calling in to our support 888.426.5214


#6

Absolutely positive, that I have both the TB3 driver and the Software Utility installed and up to date.
Device Manager shows no unknown devides or any problems whatsoever.

I got to do some further testing.
I hooked up the G-Drive (formatted exFAT) to an iMacPro via TB3 and got good read and write speeds. out of the Box.
I formatted the Shuttle HFS+ on the same mac and got good read and write speeds.

I installed MacDrive on my windows machine and got okayish write speeds of about 170MB/s on the HFS+ formatted shuttle (should be higher for a RAID 5 connected via TB3 though, right? Files I’m testing with are about 2GB in size)
Same goes for the G-Drive. When I format it to HFS+ via MacDrive I get write speeds of about 160MB/s. which I guess is okay for the single drive G-Drive. Once I format it back to NTFS or exFat, write speeds drop to about 70MB/s.

Is there also a german support hotline I can call?


#7

Support # for Germany: 49-69-29-993601


#8

For anyone with similar issues. After weeks and weeks of testing I randomly found an option to enable write cache in windows. After enabling the write cache and copying bigger chunks of data to the drive and then disabling windows write cache again, I’m seeing write rates of around 550MB/s, which is exactly what I would have expected.

Go to Device Manager and under Disk Drives select your connected G-Drive or Shuttle or what have you and select “Better Performance”. Also check both boxes for “enable write caching” and “disable windows write cache buffer flushing”.
Then take any largeish file and copy it to your device. Write cache will go bananas. After that switch the option back to “Quick removal”.

Apparently kind of overwriting the write cache once will make the drive perform normally.