Sharespace unresponsive, WD discovery won't find it, won't power down

I’m at my wits end here. I’ll try to be as accurate as possible, but I’m writing a lot of this from memory as I can no longer access my ShareSpace.

About 2 weeks after getting this Sharespace and configuring raid0 I ran into the “DataVolume does not exisit” problem… Fairly sure this was the result of a minor HDD hicup from a power-outage we had, however all drives showed up as “good” in the WD-GUI disk manager, so I was going to attempt to recover the raid (assuming it was just a fixable file-managment issue) after reading here in these forums about the difficulty in trying to recover from this, I finally decided to just start over from scratch… That’s when things went from bad to worse.

I updated to the latest firmware (2.2.9) and the firmware update seemed to work alright. I logged back into the Sharespace, checked the firmware was updated (it was) and proceeded to Volume Mangament section of the GUI. I selected the new RAID10 option, and clicked confirm when warned that this would erase all data from the drives. Less than 5 minutes or so later the process was finished (which seemed fast) so i checked the status of the Sharespace and it said raid10, but that the volume had “failed”. I took a look in the disk managment section and 3 of the 4 drives now said “foreign” instead of “good”… I noticed to the right of them there was an icon that said “clean disk” so i clicked on it for 1 of the “foreign” drives. Then something strange happened, I was popped back out to the login screen of the WD GUI, I tried my login and password again, but it wouldn’t work, so i tried the WD default login and password but that didn’t work either. I went out to the sharespace box (which is in the living room) and attmpted a reset (according to the instructions in the WD manual). The sharespace tuned on, and shortly there after all the HDD lights turned solid amber, and the power light solid green. (no flashing lights at all)… All my attempts to log back in, or even find the Sharespace with WD Discover tool come up nill. Checked “connected devices” on the router and it doesn’t show up there. I even tried to connect to it directly, and then use WD discover but with out any luck.

I’d hoped this was just part of the reset process, but looking at the WD manual, it says the power light is supposed to flash while a restore is taking place. I left this for about an hour (reading the manual and this forum in the meantime) before I decided to try and power it off, but the power button is completely unresponsive. The only way to power it down is to pull the plug. After a 6 hours of leaving it in this state I went ahead and pulled the plug. I yanked the Drives out and attempted to connect to it without any drives in it. Still doesn’t work. I plugged one of the drives (via a USB to SATA connector) to my PC and was able to see the partitions with windows disk manager… even took a quick look inside one of them with a nifty little app called “Captain Nemo” and it shows up as a linux volume.

I’m not sure where to go from here… I attempted a “hard reset” but just get the same results… Is there any hard-core/hardware troubleshooting I can do? Is the fact the ShareSpace is inaccessable on the network a sign its OS is shot? does it have a BIOS of sorts? is there a rom version of the OS/BIOS I can default back to? I’m nearly ready to just start trying random non-sense like pulling out the little battery I can see and replacing it… either that or just throw the **bleep** thing in the trash and buy a proper RAID solution form a better vendor.

Ok, so i’ve gotten a little further with it… I unplugged all but the one hard drive in drive bay 3 (the one who’s file system appeared intact when checked with Captain-Nemo app) and fired the Sharespace back up. This time I was able to log in fine. Under disk manager the drive showd as “good” and I was able to power down via the power button just fine… It’s nice to know the sharespace isn’t completely dead-in-the-water so to speak, but i’m a little concerned that I was unable to log in without any drives installed. This would suggest that the config, or something major involved in the boot process is kept on the HD? doesn’t make a lot of sense imho, but I’m just gussing that’s what’s happening. Perhaps the Sharespace is hanging as it tries to build the faulty Raid10 array?

I’ve resolved to erase the drives and start from scratch, so in troubleshooting the HDs is there any caveats I need to be aware of? can i simply plug them into my WIndows box, wipe them, and plug them back into the sharespace?  My issues booting the Sharespace up driveless have got me concerned that cleaning the drives could be a big mistake.

Now I might be wrong here, but I think this ‘Firmware’ is in fact  just software on the hard drives, and i’m sure the password IS on the hard drive.

One thing to note it that pressing the reset button takes quite a while.  You have to keep pressing until all the lights go yellow, my first attempt I released to early and had similar results to you.  I think the manual says 14 seconds or so I think mine took more like 20.

The power button needs to be pressed and held in for about 5 seconds to switch the unit off and even then it takes longer to acutely do it.

Have you tried taking the drives out - plugging them in to the PC and running ‘Spinrite’ on them www.grc.com ?  If its under warrenty I’d take it back to the shop.  I would take mine back but I have 6TB of data on it and no way of backing it up.

I tried holding the reset button for every interval I could find reference to. First I tried the “hard restart” holding for a minute prior to powering on, and continuing for a minute after adding power… all with no result/change… My attempts to power down were equally extensive, after trying the normal 10-15 sec, i tried holding in the power button for a minute, and nothing happened… There was definitely something effectivly freezing all operation.

After much troubleshooting/reading i’ve managed to get a bit further along with it tonight. It seemed to hang only when all 4 drives were in place, creating the total unresponsiveness i described. I was however able to boot up with just 2 drives installed (bays 2 and 4) and then created a mirror array using just those 2 drives. Under the advanced tab in the GUI i switched “auto add to array” to “manual”, saved, powered down, Then I put the other 2 drives back in and rebooted. I am now able to boot with all 4 drives physically installed (drive 2 and 4 are in mirrored mode, and drives 1 and 3 are not assigned) but it seems that regardless of which of the two remaining drives I place into bay number 3, it appears as “failed” under the WD-GUI-Disk manager… The “failed” drive always appears in bay 3 (while the rest all come up as “good” , with drive 1 reading as “unassigned” as it is not yet part of any raid.)…

My first thoughts are that perhaps there is something wrong with drive bay 3 on the WD-Sharespace case, however when I place just a single drive into that particular bay (all others removed) the WD boots up fine and the drive shows as “good” which makes me think perhaps this is just a side effect of the two drives (1 and 3) not being part of an array, or still containing erroneous Raid10 settings from my previous attempt at configuring them.

I will look into that “spinrite” app and perhaps I can use it to clean up whatever is causing the issue. Other than the “clean disk” option in disk manager (which does not appear for “failed” drives) does anyone know a way to properly format a “failed” disk for use with the sharespace? I can see all the partitions in Windows Drive Manager, so I don’t think there’s anything physically wrong with the disks. I’m hoping cleaning them of any prior settings might make the Sharespace happy enough to play nicely.

I would advise you return to a raid 5 or raid 0, 0 being the fastest - 5 slower and 10 - stripe mirror seems pointless unless your putting in the likes of a IBM DS5020 /XIV of the like or an N series systems, not worth it on so few drives bro… if your still in warranty open a call or RMA it.

ZippyDaMCT wrote:

I would advise you return to a raid 5 or raid 0, 0 being the fastest - 5 slower and 10 - stripe mirror seems pointless unless your putting in the likes of a IBM DS5020 /XIV of the like or an N series systems, not worth it on so few drives bro… if your still in warranty open a call or RMA it.

At first I would agree with you, but after reading this board a bit, and experiencing the unreliability that is WD’s Sharespace, my only concern at the moment is getting this silly thing up and running again with as much potential redundancy as possible. My initial problem was with the “Data Volume Does Not exist” error, and it seems that even with RAID5 most people were forced to reformat, or painstakingly recover their data, then reformat. The normal recovery you’d expect from a RAID5 isn’t an option. With these painful lessons in mind, I have resolved to use RAID1 or RAID10 in the hope that recovery the next time round is not an issue.

So last night I managed to use the “clean disk” option in drive manager on the ‘unassigned’ drive that was installed in bay #1, after a few minutes it came back as “new” , the drive in bay 3 still was listed as “failed” with no options so I powered down, swapped drives from bay 1 and 3 and booted back up… Now the newly cleaned disk showed up fine in bay 3 (as “new”) and I was able to “clean disk” on the drive now installed in bay 1…

With all the drives working (2 in raid1, and 2 as “new”) I went ahead and tried once more to modify the Sharespace to use all 4 drives in RAID10 … The reformat process seemed to be going ahead fine (checked in on it every hour for about 4 hours, then went to bed)… When I checked the status this morning, it seems to have competed but is running in “degraded” mode. The strange part is the disk that is having problems now is the one in drive bay 4! This drive, and this drive bay, have been fine during all of my other troubleshooting. I had just previously had drive 4 (along with drive 2) configured in a working, stable, 2 drive mirrored raid.

Checking the logs it appears as though the drive disappeared for a moment then came back and failed it’s SMART test… Here is some of the output from my log:

 11/06 10:05:13  MEDIABOX daemon.alert wixEvent[936]: hdd_thread - SCSI ioctl error !
 11/06 04:59:16  MEDIABOX daemon.alert wixEvent[936]: hdd_thread - SCSI ioctl error !
 11/06 04:37:34  MEDIABOX daemon.alert wixEvent[917]: HDD SMART - HDD 4 SMART Health Status: Failed.
 11/06 04:37:20  MEDIABOX daemon.alert wixEvent[936]: hdd_thread - SCSI ioctl error !
 11/06 04:15:26  MEDIABOX daemon.alert wixEvent[936]: hdd_thread - SCSI ioctl error !
 11/06 03:53:59  MEDIABOX daemon.alert wixEvent[917]: Volume Status - Volume ‘DataVolume’ is in degraded mode.
 11/06 03:53:40  MEDIABOX daemon.info wixEvent[917]: iTunes Server - iTunes server find the path to /Public/Shared Music.
 11/06 03:53:36  MEDIABOX daemon.alert wixEvent[936]: hdd_thread - SCSI ioctl error !
 11/06 03:34:32  MEDIABOX daemon.info wixEvent[917]: HDD Status - HDD 4 is found.
 11/06 03:34:26  MEDIABOX daemon.alert wixEvent[917]: HDD Status - HDD 4 is absent.
 11/06 02:48:31  MEDIABOX daemon.warn wixEvent[917]: Volume Status - Volume ‘DataVolume’ is resyncing, 80% had completed.
 11/06 02:05:00  MEDIABOX daemon.warn wixEvent[917]: Volume Status - Volume ‘DataVolume’ is resyncing, 49% had completed.
 11/06 01:21:25  MEDIABOX daemon.warn wixEvent[917]: Volume Status - Volume ‘DataVolume’ is resyncing, 14% had completed.
 11/06 01:21:13  MEDIABOX daemon.warn wixEvent[917]: iTunes Server - iTunes server cannot find the path to /Public/Shared Music. Please verify that the folder name has not been changed.
 11/06 01:05:07  MEDIABOX daemon.warn wixEvent[917]: Volume Manage - Volume ‘DataVolume’ created.

Ignoring for the moment the strangeness of my present problem occurring on a drive that had previously run fine, my plan is to pull the drive, and run some diagnostics on it “spinrite” the see if I can get it goin on my windows box. I’ll post my results…

update: spinrite, along with WD lifeguard HDD utility both found that drive 4’s Smart settings were failing, ie the drive was on it’s way out. I used the deep scan, and rebuild feature to recover it enough to pass the SMART test, and plugged it back in the sharespace after work… With all drives listed as good (at least for the moment) I let the Sharespace run it’s “recovery” process on the RAID10 system. Got up this morning to see that the raid is functional, but once again running in degraded mode, with “HDD 4 SMART Health Status: Failed.” in the log… I’m going to replace the drive, and see if that will FINALLY fix things. FIngers crossed…

Ok, so I bought a new WD drive (same model and size as others) installed it and let the Share space “resync” my Raid10…

This was my log:

11/17 12:42:34  MEDIABOX daemon.alert wixEvent[1025]: hdd_thread - SCSI ioctl error !
 11/17 12:21:06  MEDIABOX daemon.alert wixEvent[1017]: Volume Status - Volume ‘DataVolume’ is in degraded mode.
 11/17 12:20:43  MEDIABOX daemon.alert wixEvent[1025]: hdd_thread - SCSI ioctl error !
 11/17 12:04:19  MEDIABOX daemon.info wixEvent[1017]: HDD Status - HDD 4 is found.
 11/17 12:04:15  MEDIABOX daemon.alert wixEvent[1017]: HDD Status - HDD 4 is absent.
 11/17 11:59:14  MEDIABOX daemon.warn wixEvent[1017]: Volume Status - Volume ‘DataVolume’ is resyncing, 97% had completed.
 11/17 11:15:41  MEDIABOX daemon.warn wixEvent[1017]: Volume Status - Volume ‘DataVolume’ is resyncing, 72% had completed.
 11/17 10:32:08  MEDIABOX daemon.warn wixEvent[1017]: Volume Status - Volume ‘DataVolume’ is resyncing, 38% had completed.

The drive shows up as “good” in drive manager, but the size of the volume for that drive remains “undfined” and the raid10 continues to run in degraded mode… :(   I can use the Sharespace fine, but I’m really getting sick of looking at that flashing red light… Is there somthing I’m doing wrong with my reinstallation? The log would suggest that everything was going fine up until 97% complete, then instead of finishing the sync it’s wigged out…

Edit::: Ok, so now the log is saying that the SMART data for drive 4 has failed… Same as with the previous drive… I’m beginning to think that DRIVE bay 4 is faulty… This would seem to explain the recent problems, but does not explain the previous symptoms (in which dirve 3 messed up and drive 4 worked fine)…