Upgrade Sharespace 2TB with 2x WD10EARS?


#1

Hi everyone,

I have a Sharespace 2TB with 2x 1TB hard drives and contacted WD support to ask them which drive I should buy if I want to upgrade it to 4TB.

They said that ANY CAVIAR GREEN drive will work.

So I ordered 2x WD10EARS.

I have not installed them yet because browsing through this forum I read:

a) Caviar Green drives are NOT RAID COMPATIBLE

b) EARS-drives don’t work in Sharespace

So which is true? Should I send my drives back and get WD10EADS?

Thanks

Matt


WD sharespace and WD Caviar® Green™ hard drives unavailability
WD Sharespace and 2TB drives
#2

Sounds like what I did.  I bought 2 x WDC WD20EARS-00MVWB0 (2TB) disks.  Originally I had  2 x WDC WD10EACS-00D6B0 (1 TB).

I can confirm that they works.  Please note that I wanted to add new disks in free slots, not  replace existing. I run into some problems. The solution was:

  1. Copy all data on original 1TB RAID1 to another location. Note!  T akes very long time.
  2. Remove disks
  3. Install new 2TB disks in Slot 1 & 2
  4. Create 2TB RAID1 Volume “DataVolume” and format
  5. Install old 1TB disks in Slot 3 & 4
  6. Create 1TB RAID1 Volume “ExtendVolume” and format
  7. Copy data back.

Simply adding the new disks in slot 3&4 did not work. Please note that  WD support told me this configuration would not work :smiley:

I believe any Green HDD will work simply because the ShareSpace has a limited power supply and that is the single reason other WD drives are not supported.

See also this thread Creating a second RAID1 Volume

Including a screendump for reference:

wdcDualRaid2.jpg


#3

Thank you for your detailed response.

I was actually hoping to use RAID-5 and not 2x RAID-1

Did anybody try a RAID-5 with EARS drives?

Thanks

matt


#4

Matt,

I’m currently running 4x WD20EARS drives (each with pins 7-8 jumpered) and have had no issues for the last 2 months. I would recommend a backup however, just incase.

Also running on a UPS to reduce the chance of OS failure.

  image1.jpg


#5

Thanks guys. I will go for it and install my 2 new WD10EARS. I’ll let you know how it works out :slight_smile:


#6

Just an update: I bought the 2 drives WD10EARS, put them into the box and they work in RAID-5 with the 2 pre-existing WD10EACS.

Here’s what I did (everything entirely straight forward):

  1. Backup of all data to an external hard drive

  2. Upgrade the firmware to the latest version (2.2.91)

  3. Shut down Sharespace

  4. Open it + place the new drives into bays 3+4 (no jumpers, no nothing. Just took the new drives out of their boxes, placed the green plastic thingy around and pushed them into the vacant slots)

  5. Start Sharespace

  6. Login to the admin GUI + reset Sharespace to factory settings (Advanced Mode =>Configuration => Button “Factory Default Restore” at the very bottom)

Since the factory settings of a Sharespace with 4 drives is RAID-5, Sharespace automatically deleted all my files and created a RAID-5 for me after I reset it to factory defaults. This took 16 hours which is ok since it only needs to be done once.

After that, I logged into the admin GUI, created the users and shared folders anew and copied my data back. Done.

Well, I am still copying the data back (7 MB/sec max. so my 1 TB of data will take a while…)

So it seems to be possible to mix the old EACS drives with the new advanced format EARS drives. I also didn’t have to take the existing drives out of their slots or jumper the new ones.

I hope this configuration will now work for the next 2-3 years…

Matt


#7

Cool!  Thanks for useful report.


#8

Nasexplorer,

Can you please provide the steps you took to get your WD Shareshare to work with the new 2TB drives?

I have an existing 4TB WD Sharespace that I have been using for several years that has worked very well for me for the past few years. I recently ran out of disk space and purchased (4) 2TB WD10EADS drives, instead of the EARS version as I had read there were possible incompatibility issues with the “EARS” variant.

Here is the trouble I am having, I removed the cover, pulled the (4) existing 1TB drives and installed the (4) new 2TB WD10EADS drives, after powering on the power light just flashes. I pulled up the documentation on what the flashing light indicates one of the following:

System is booting

System is restoring to factory default

System is configuring RAID on the hard drive(s)

System is configuring RAID 0, Span, or RAID 5 on a volume User volume is not available

Since I am in no major hurry here, I just spent the past week painstakingly backing up the data from the original drives I decided to leave it alone and let it possibly do one of the above tasks, it has been nearly 60 hours later and the power light is still flashing and I can’t login to the web admin interface, the network adapter is lite however the device does not ARP on the network so the interface isn’t available (I believe the technical issue here is a bug in the firmware that doesn’t allow the ethernet interface to come up PRIOR to the disks being available, this is a terrible flaw… moving on)

I try to push the power button to no available, the only option is to unplug the power cord. I tried powering it back on and it goes right back to this blinking power light state. So I pull the 4 new 2TB drives out, put the original 4 1TB drive in and power it on, and it boots up fine and I can login to the web admin interface.

So now I have read these forums for the past 40 hours learning what people are doing to get a partial two disk volume installed and I just don’t have time to mess with trial and error. I’d like to review your steps and then I am going to take the time to create a step by step guide for others to follow when upgrading from the 4TB Share Space to the 8 TB Share Space including what drives are compatible, etc.

Can you explain to me what the jumpers are on pins 7&8? My original 4 1TB drives do not have any jumpers on those pins, is this something related to the “EARS” model? Right now I have booted up the NAS with the original 4 1TB drives and I have just reset it to factory defaults and it’s rebooted and now it’s in the process of building the RAID volume *sigh*. 1000minutes to go.

I am going to power it down and try someones suggestion of installing 2 drives and then resetting to factory defaults and then having it build a 2 disk volume, when completed I guess I will power down install 2 more drives and then hope to delete the old configuration again? You would think someone at WD would take an Engineer over there and re-create this issue of a 4TB to 8TB upgrade, document the issue and create a work around document for everyone with this issue and then create a firmware patch to resolve this issue.

WD Folks: Listen up, here are some recommendations to resolve this issue:

  1. Enable the Network interface at boot up, allow users to web into the interface if there is a disk issue.

  2. It’s possible the reason new disks aren’t initializing is due to custom volumes that were configured on the original disks and the only way to get rid of this information from the settings is to reset it to factory defaults, however you can’t reset the factory defaults if you have install the new drives. The unit won’t allow you to boot it or log into it.

This is a very simple resolution, why isn’t it being addressed?

Take a 4TB ShareSpare unit that has some custom configuration in it such as a couple users, a couple custom disk volumes, copy some random files to it and then process to try to upgrade it to an 8TB unit in a lab environment, you will be able to recreate exactly what is happening in 15 minutes and create a work around document for your CUSTOMERS to resolve this easily until you can create the next firmware patch to address the disk capacity upgrade issue.


#9

Update:

Following Matt’s recommendations for how he is adding 2 additional drives I decided to pull out the original 1TB drives from bay #3 and bay #4 and replace those two units with 2 2TB drives, after powering on the device I can clearly see it’s

working properly and it’s attempting to build an array from the disk activity lights, however I have no idea what it’s trying to build.  This is most likely due to interrupting the original process of trying to build a Raid 5 array over 4 1TB drives, so I’m assuming I’m going to have a Raid 5 over 2 1TB and 2TB drives (not what I want, but it appears to be completely out of my control and it’s going to do whatever it has to do for the next 1000 minutes.)  

*** I can get to the web UI with two 1TB in bay #1 and bay #2 and two new 2TB drives in bay #3 and bay #4. ***

I decided to power it down once more and replace the (2) 1TB disks in bay #1 and bay #2 and turn the unit back on.  When I turn the device back on I can clearly see it’s NOT working again, the power light is just flashing and the disks are not doing any syncronization. 

I attempt to login to the web UI and it’s not accessible (The device isn’t sending ARP’s to the switch).   So the network interface has never come up in Linux, most likely due to the disk’s not coming up and the boot process has haulted. 

So I remove all the drives and take drives from bay #3 and bay #4 and insert them to bay #1 and bay #2 hoping that would do something, booted the device back up and smae problem.   Blinking power light, no IP address on the device (not arping).

I’ve powered down the device a final time, installed 2 1TB drives back in bays #1 and #2 and I have (2) 2 TB drives in bays #3 and #4.    I’ve powered up the device and it’s attempting to build some type of Raid 5 system (1%, Estimated Time: 970.6min)  16 hours!

I will report back with what I have listed under disks in 16 hours, I can’t believe there isn’t an option to stop building this array and let me modify it…

I can’t wait to hear back from someone that has (4) 2TB drives working and what step I am missing!


#10

Hi Jliford,

Waiting for the Sharespace can be a pain sometimes. Let me first say that the only reason I chose the EARS drives was because I couldn’t source any EADS ones here in Australia. I can’t see why it would not work though.

 I don’t think you have to worry about the jumper setting as this only applies to the EARS series (2TB and above)  - (sector alignment etc).

A few things I would suggest would be:

  • With your original setup - so you can access the web interface again -  In advanced mode, System Tab, Advanced icon, under “Extend Span”, Mode - change to “Manual”

  • I would then power down the device, remove all drives and add one of the new 2TB ones and power back on. Hopefully the device should initialise OK and register the drive as new and valid

  • If all good, power down and add the second drive and so on until all four drives are installed and working.

  • Then you can choose the RAID level you want and let it format (probably for the next 2-3 days)

If you have no success after adding the first drive, perhaps a full factory reset may help.

Nasexplorer.


#11

Nasexplorer,

Thank you very much for your prompt response!  Excellent advice and it worked exactly as you described it and that little check box is not something I would have ever considered, even though I knew the problem was in relation to the disk syncronization.

I logged in this morning (it was still formatting from last night, however the web admin interface was working this morning).  I checked the box you mentioned to manual and installed 2 2TB drives and presto, it booted up and worked as it should.    I just powered down and repeated the process by installing the other 2 2TB drives.

I just powered the unit back up and I clearly see disk activity taking place.  I just logged in and I can see all 4 2TB drives now, 2 are assigned to “DataVolume” and 2 are “Unassigned”.

The only question I have is do I go back and set that flag to “automatic” or leave it manual and setup the disks manually.  I don’t want to have to go through that silly process of installing the old drives again in order for the WD ShareSpace to allow me to login to the web interface.

The major bug with this product is that you can’t login to the web interface if you have 0 disks installed in the unit.  If that was fixed this product would be a fine home office solution that doesn’t require fast disk transfer speeds of course.

Thanks again for your prompt response and your spot on technical recommendation.  If you don’t work for WD you should get consult for them on this issue and write a document for them to patch this in the next firmware release.

Kind Regards,

Jeff Liford


#12

Nasexplorer,

I went ahead and went into the Storage/Volumes & RaID Management -> Manage RAID and changed the “Span” setting to “Raid 5”.

It is now in the process of resyncing/formatting, it indicates it’s using all 4 disks and the current status is “Recovering”

This all looks normal to me, please let me know if this is the way you would have recommended it or if you would have gone back into the setting you mentioned before and set it to “automatic” mode.

The reason I ask if you have already been through this and learned what and what not do to and I don’t want to be in a situation that because I didn’t set a proper setting I possibly loose all my data down the road.

Thanks again!

Jeff Liford


#13

Jeff,

Now that’s really good news!

  

I agree with you, it’s destroyed the old volume and now in the process of creating the new four disk RAID 5 (which will probably take 2-3 days).

  

I’ve left my setting on “manual”, just so as to give more control, however I doubt that you (or me) will be destroying/changing RAID types in a hurry due to the time it takes to backup/resync/format :slight_smile:

  

Also, I don’t believe that this device is worth upgrading beyond 2TB per disk - probably better to invest in a second or replacement NAS.

  

I’ll be trying a test disk failure soon (after I backup my data) and report back on success or failure.

  

Only other advice would be to keep a working backup of all or important files.

  

Glad I was able to help.

  

Cheers,

  

Nasexplorer


#14

Nasexplorer, It’s Friday, January 28th and the drive is still in a “Degraded” Status. Any suggestions? Jeff


#15

That means one of your drives has crapped out. You need to see which one has failed.


#16

Umpa2011, When I click on the Disk Manager is says the status is “Good” on all the drives, however when I click on the Manage Volume tab is says: Volume Type Disk Usage Size Status DataVolume Raid 5 1 3 4 Unknown Unknown Degraded Under “Disk” those numbers change, now it displays Disk #1 & Disk #3, I refresh the browser and it displays Disk #3 & #4, Refresh again and its Disk #1 & Disk #3, Refreshing again shows Disk #2 and Disk #4. I’m assuming this “Desk” area should show Disk #1, #2, #3, and #4 all the time for the Raid 5 Volume. The drives appear to be fine according to the “Disk Manager”. I can take them out and test them using some SMART disk tools, if I really have to do that. Seems to me this is another BUG.


#17

Umpa2011, I went into the RAID 5 configuration and there were some more options this time for some bizarre reason. Originally there was only 3 choices, this time there was 4. I selected RAID 5 again, it’s select for Disk #1,#2, #3, #4 and the Status is “Recovering” 3 more days to wait. If this doesn’t work I will go back to 4TB and return the 2TB drives, what an incredible waste of time and resources, I’m very disapointed with Western Digital now and I have always pushed WD products.


#18

Jeff,

May want you have a read of this page:

http://www.smallnetbuilder.com/content/view/30586/75/1/2/

 You may get better results if you remove all disks, then adding one at a time and preforming a  “Clean Disk” function on each, then begin a RAID5 config on “new” disks.

Nasexplorer


#19

Heres what I would do, I would sit tight and let it finish the recovery.  Sopping the thing midway can only cause problems.  It sounds like its doing the tight thing to me.  I know its a ball ache and an incredible slow process.


#20

Hi, I just bought a new sharespace with 2x1Tb Drives in it.  I purchased another 2x1Tb which were western digital green drives.  I didn’t take note of the particular model but I did notice that the new ones had a bigger cache than the ones that were in ther (64 vs 8)  so I’m pretty sure they are different models.   I put them in and managed to setup a Raid 5 array (it took 16 hours) with the 4 drives but it’s incredibly unreliable.  I was trying to access it from my desktop and my laptop concurrently and the connection to the network drive would continually drop out and I would get sharing violations on files I was copying after which I couldn’t access the files.  I can browse the drive from my desktop but it tends to crash explorer (windows xp).  My laptop is running windows 7 and it only see’s the drive intermitatly.  The laptop is connected by WiFi the desktop is connected through ethernet.  The desktop has a gigabit ethernet card in it but I’m pretty sure the router is only 100Mbs.  My thoughts are that it is probably something to do with mixing the different drive types but I’m not sure.  When I go home tonight I will note the drive models.  It’s very frustrating as my desktop computer is playing up and I need to back everything up on it.  I’m going to try replacing the ethernet cable just in case it’s something to do with that but I’m not hopeful that it will be as I can use the web interface to the box without any problems.