Share Access- Username Password

I know this has been a frequent problem but nothing I have tried has worked. On my Windows Vista PC all network setup items are enabled as required. My PC is recognizing my WDTV Live Hub on my home network. I am running the latest WDTV Live Hub firmware. Workgroup names are the same. Network password protection is disabled on my PC.

When I try to access network shares as a source on the WDTV Live Hub I get a menu listing “Windows Shares”. I accept that and then the WDTV Live Hub takes about 4 to 5 minutes (circling arrow) to finally list my PC as a network share source. When it finally appears I select it and then get the username password window which I leave as “anonymous” and “*****************” respectively. I then hit OK on the green check mark, get the circling arrow for another minute or so, and then get an “invalid username / password” message.

I have searched the forum for a solution. I have tried resetting the WDTV Live Hub, etc. Any help will be much appreciated.

I’ve been having this exact same problem for over a month now. Everything worked seamlessly for at least a year and then suddenly a month or so ago BAM!!! Incorrect Username/Password. Its a hit and miss situation for me. Sometimes I get in on the first shot, sometimes it takes 5 - 10 trys and other times I can go a half an hour without any success and then I give up. I have 2 LIVE HUBS that get the same error. I’ve been in contact with the manufacturer for my NAS and they haven’t found any solution on their side.

Here are some things I tried but with no success:

  1. Reset LIVE HUB.

  2. Changed ports on my router.

  3. Reboot router & modem.

  4. Reset modem & router.

  5. Created specific user to connect to my NAS.

  6. Tried previous firmware and most recent.

  7. Tried different themes and default theme.

  8. Tried user anonymous.

Hopefully someone here can help out.


Thanks for replying RACL.

I’ve tried eveything you have tried without success. At least you are able to get to your shares some of the time. I am really perplexed by how long it takes after I select the green checkmark on Windows Shares. I get the circling arrow for 4 to 5 minutes before my computer name appears. When I finally see my computer name pop up, I select it, hit the green check mark, accept the default anonymous username and password, hit the green check mark again, get a circling arrow for another minute or so, and then get the invalid username / password message. I can’t ever get beyond this point.

Hopefully someone can help.

Based on some troubleshooting techniques provided by Tony in another thread, I have confirmed that WDTVLiveHub is being set as the master browser in my network. I believe this has something to do with my inability to see network shares in my network. I have tried everything I know to prevent WDTVLiveHub from becoming the master browser, but, try as I might, it always does.

Any insights or help will be much appreciated.

Problem resolved by upgrading to Windows 8.  My Vista OS was obviously corrupted. There was no problem with my WDTVLiveHub or the firmware.

Thanks to those who replied

I started having this problem with Seagate GoFlex Home NAS just after Daylight Savings Time went into effect.  I discovered the WDTV Live Hub has a DST setting and it was turned off.  Turned it on, restarted the device, and can now log into NAS with existing username and password.  I guess the clocks on the different devices did not agree!?!