Invalid username or password - Windows XP!


#1

[Okay, first, let me preface this by saying I am using Windows XP, not Win7, so the millions of topics already covered don’t concern me :wink: I also don’t have Windows SignIn Assistant.]

I just got a WD TV and it finds the computers but is unable to connect to the shares. Every error is “Invalid username or password. Please try again.”

I tried two working accounts and I know the passwords work, but it just doesn’t happen on WD TV Live. Why?

note:

I already tried this: Home -> Settings -> Clear Login Info


#2

Welcome to the forums.

I’d definitely start by removing the passwords from your net shares (you may or may not add them back in but for now we want to simplify things as much as possible).  Next, makes sure both the Live and your PC are part of the same workgroup (and it’s a good thing to call it “Workgroup”, as that is the default for the Live).

Try that and let us know what happens.


#3

tamar wrote:

[Okay, first, let me preface this by saying I am using Windows XP, not Win7, so the millions of topics already covered don’t concern me :wink: I also don’t have Windows SignIn Assistant.]

 

I just got a WD TV and it finds the computers but is unable to connect to the shares. Every error is “Invalid username or password. Please try again.”

 

I tried two working accounts and I know the passwords work, but it just doesn’t happen on WD TV Live. Why?

 

note:

I already tried this: Home -> Settings -> Clear Login Info

 

 

What firmware are you using?

Have you updated the firmware lately?

Try:

resetting the WDTV by using the side button

resetting to factory defaults using the internal menu

unplugging the unit from the power for some minutes.

Do all 3  things one after the other before attempting to use the unit again.

As Mike says its always best to get things working without passwords in the first place, they tend to make any troubleshooting difficult. If you have no user name or password then its just a simple case of leaving everything at its default and pressing OK to connect. 


#4

Mike, I tried that, no dice. I’ve cleared the passwords and reset to factory defaults.

Using no password did not work. According to a help article I stumbled upon last night, apparently a password is necessary for WinXP. Am I wrong?

I am trying to upgrade from firmware version 1.0.21 to 1.03. Sadly, *I can’t find the firmware upgrade option at all on my device!* Is it missing or am I totally blind? I have the firmware on a USB key.

My device was shipped with 1.0.12 at first, and it found two firmware upgrades manually over the Internet, but when trying to upgrade to 1.03, it just says “your device is up to date” so it doesn’t even let me do anything.

My settings menus – and I looked at them about 10 times – do not have firmware update options. Then again, it could be that I’m blind.


#5

You tried what?  Setting the workgroup on your PC to “Workgroup”?

You don’t need a password on your XP shares (nor on any shares).  But I’m a bit more worried about getting the firmware.  Did you go to “Check for updates” in your Settings menu?  And how are you connecting, wired or wireless?


#6

I tried all of that.

In other words, my workgroups on my PC are already “workgroup” so nothing needed changing.

I also created a guest account last night and removed passwords, but even then, I couldn’t get in (same error, Invalid username or password). That’s when I discovered something (in the official WD Help) that said that XP requires a password. Whether or not that’s true I guess isn’t an issue yet… I have a more pressing issue related to firmware right now as you mention.

I’m connecting via wifi. But I successfully upgrade twice to 1.0.12 -> 1.0.17 firmware last night, and then I upgraded from 1.0.17 to 1.0.21 firmware via wifi. That’s becasue when I powered on the WD Live, it immediately found the firmware upgrade.

That’s not the case right now. It says my unit is up to date and I cannot find for the life of me a way to upgrade via USB. :frowning:


#7

Just to humor me, create a brand new share (create first a new folder, put at least three playable files in it, then click on properties and create the share, and in advanced make sure you add “everyone” to that share and that passwords are off and try connecting to it with the Live).  Let us know what happens.


#8

At this point, I’m more concerned about not getting the firmware as it apparently addresses this issue. As it is, I created multiple shares with multiple usernames last night to no avail.

I just got off the phone with WD and they confirmed that my device is defective.

Bummer.


#9

tamar wrote:

Mike, I tried that, no dice. I’ve cleared the passwords and reset to factory defaults.

 

Using no password did not work. According to a help article I stumbled upon last night, apparently a password is necessary for WinXP. Am I wrong?

 

I am trying to upgrade from firmware version 1.0.21 to 1.03. Sadly, *I can’t find the firmware upgrade option at all on my device!* Is it missing or am I totally blind? I have the firmware on a USB key.

 

My device was shipped with 1.0.12 at first, and it found two firmware upgrades manually over the Internet, but when trying to upgrade to 1.03, it just says “your device is up to date” so it doesn’t even let me do anything.

 

My settings menus – and I looked at them about 10 times – do not have firmware update options. Then again, it could be that I’m blind.

From what you are saying it appears that you may not have a WDTV Live.

What is the model of your unit because I cannot find your firmware anywhere.


#10

richUK: I got off the phone with WD directly just about 2 hours ago. He matched the serial number to my device and even told me my warranty information so I most definitely have a WD TV Live.

In case you want to know, I purchased it from this direct link: http://www.newegg.com/Product/Product.aspx?Item=N82E16822136472&Tpk=wdtv%20live

Now what I’ve found out is that I *do* have the correct firmware as per this page: http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_live

I was incorrect as per my original firmware versions - my apologies. I didn’t realize I’d have to recall them! In fact, I asked for WD support via email and he sent me to the WD TV page, not the WD TV Live page, which is why I was totally confused about firmware updates :frowning: (This one doesn’t match my device!  http://www.wdc.com/en/products/WDTV/ but it’s what they gave me! Gah, way to confuse everyone! Sorry!)

So… maybe it’s not broken and the guy on the phone was wrong. I guess I’m still just having problems with Windows shares :frowning:


#11

You still keep confusing me when you say you created multiple user accounts and multiple shares – forget multiple accounts.  If you have your shares set to “everyone” you don’t need any user accounts (because without a password you can login as ANYONE and it will work).

So – bring up the settings on one of your shared folders (the advanced settings) and tell us *exactly* what it says there, in all the boxes (including what’s checked and what isn’t – a screen shot would be best if you could post it somewhere and put a link here).


#12

What build of WinXP do you have?  WinXP Pro?


#13

WinXP Pro SP3.

And yes - I had the permissions set to Everyone. I still couldn’t get in.

HOWEVER, for some reason, it seems to be working now. I’m not sure why that is or what I did, since I didn’t do anything different… in any event, I’m super confused myself and I’m just going to take what I have since my blessings are limited :wink:

Thanks all for your help!


#14

Problem:
Cannot automatically access password protected Network Shares after upgrading from 1.01.24 to 1.02.21 on the WD TV Live HD Media Player.
Cause:
A new SAMBA module was installed in the 1.02.21 firmware release causing stored passwords to become invalid.

Solution:
Please follow the instructions below to solve this issue:

Navigate to Settings/Network Settings and set the automatic login feature to "Off.
Clear the save password setting.
Navigate to Video and select the Network share.
At the login screen, enter the username and password to open the Network Share.
Make sure that the video content can play.
Navigate to Settings/Network Settings and set the automatic login feature to "On.
The Network Share should now be visible and able to access the content without logging in.