Several issues - Pleas Advise

Dear all,

I have the following problems with my 2 TB WD Wireless Passport:

  1. When i try to copy my data on the HDD it says that i do not have permission. On another laptop that i have, i can do this. I have installed all the software but it does not work.

  2. When i copy files and want to stream them via WIFI on my IPAD, it does not show all the files. It shows the initial files i have copied a while back but not the new ones. I can stream through VLC per say but only the first files i have copied. The new ones do not show…

LE Update on my second problem: now i have conected my laptop to the passports WIFI and i see the hdd as “Network Drive”. When i go in to see the data, i can see folders with movies for example that on my direct connection (hdd with laptop through cable) i can not see…

Hi and welcome to the WD Community. Have you tried downloading the latest firmware update (1.03.13)?

yes, i did download the firmware and did the update and did not solve the issue.

When you connect via a USB cable you are using the permissions defined by the computer you have connected the MPW to.

When you connect via Wi-Fi you are using the permissions defined by the MPW and the My Cloud or any other app you use.

Obviously you don’t have permission to see some of your files when connected to one of your PCs via USB. Fix your permissions.

With the MPW security is achieved by your ability to connect to the drive wirelessly.  Share level permissions are not used on the MPW (MyPassport Wireless).

So, if direct-connect ot hot-spot mode then the connnecting devices need to know the Wireless secret key.  If in network mode then then anything on the local area nwtwork can access the MPW’s content.

RoderickGl is right. If it’s a permissions problem then it’s not on the MPW.

Thanks but this addresses only my first question.

On the 2cnd question i still did not get a definitive answer not even from WD Support.

I did the update an after that to rebuild the Media Count in the mypassport.local app. This seemed to solve the issue for the moment but when i tried to copy something else, the same problem returner. This is very strange.

First, you need to read and understand the section in the User Manual titled “Playing/Streaming Videos, Photos, & Music” on page 39 of the PDF version of the manual, which can be downloaded from WD if you don’t have it already. (I like to use PDF versions of manuals as they are searchable. Much easier to find information.)

Next, you should understand that there are three ways to see the media on the MPW.

First, when you connect the MPW to a PC using the USB cable, it acts entirely as a local USB drive. You should be able to explore the drive using Windows Explorer and see everything on the drive, except of course the OS in firmware. (Note: I’m assuming that your PC is a Windows PC, but you haven’t said. If it is an Apple just substitute the equivalent applications.) You can even see directories that start with a “.”  (dot), which include the DLNA database, for example. While you are looking around in there, find and watch all the WD MPW videos. They are very good and answer lots of questions. Here is what this method looks like on my PC.

View when connected via USB.jpg

Second, the MPW can act as a Network Drive, and based on my experience when this is done all files are shared automatically, but you are restricted to certain directories. Well, actually you can see the Public directories on the drive, which include nearly all of them, but not the DLNA database and cache, plus you can see the SD and explore it if a card is inserted. However that may be the case because when the MPW connects to my home network, it is automatically trusted, as I have my local network set up that way. i.e. To trust local resources with an IP Address assigned by my router.

The MPW acts as a nework drive when it is connected to your home (or other) network, and you connect to it via the same network. It also acts as a network drive when you connect to it directly as a wireless hotspot.

Here is what this method looks like on my PC. (I’ve covered the real names of my computers and the MPW to protect the innocent.)

View when connected via Wireless on my network.jpg

Third, you can connect to the MPW using DLNA. The MPW has a DLNA server which can be turned on or off. Obviously you have discovered that as you have rebuilt the Media Database once already. You should not have rebuilt the Media Database by they way, as it just takes lots of time unnecessarily. You should have just refreshed the DLNA Database and it should have found your new files. Basically the Media Database and the DLNA Database are the same thing, as shown by the popup descriptions in the web interface (Dashboard). I suspect the the Media Count section on the Dashboard Media tab refers to all files on the MPW, while the DLNA section on that same tab refers only to files that can be served up via DLNA. which is a subset of all files.

BUT HERE IS THE IMPORTANT BIT: The MPW takes a while to find new media files. The MPW runs a background process to look for changes in media on the drive. The status of this proces can be checked via the Media tab on the Dashboard, and is called the “Scan Activity” under both the DLNA and Media Count sections. If you just added files and want to see them immediately via DLNA, then Refresh the DLNA Database. Then check that the Scan Activity is idle, and the time it finished is after you loaded the new files. Or just leave the MPW turned on for half an hour after loading new media, and it should find the files.

You have to use a DLNA Controller to connect to a DLNA server and tell it what to do. The media is then played on a DLNA Renderer as directed by the DLNA Controller. I suspect that the My Cloud App is both a DLNA Controller and Renderer. But it can also act as just a Media Player when the MPW is connected as a Network drive and the DLNA server is off. This is not really media streaming though, and doesn’t benefit from functions that a DLNA server can provide, such as caching and transcoding of media. I can’t really tell if the My Cloud App works as a DLNA Renderer though, or is just acting as a Player. It does seem to work a bit better if the DLNA server is turned on though.

VLC, which you mentioned above, can also act as a simple Media Player, but also as a DLNA Controller and Renderer.

So, when you connect the MPW to your network, and copy a new file to it using Windows Explorer, is the file immediately visible on the MPW acting as a Network Drive? 

If so, can you double click on the file and if so, will Windows try to open the file and play it? Whether it can play it or not doesn’t matter, as that is entirely dependent on the software you have installed on your PC and the default actions you have set, plus file associations.

If that works, is the file visible in the My Cloud App?

What is the status of the Scan Activity?

If the file isn’t visible, and the Scan Activity shows as idle, does clicking the DLNA Database Refresh, and waiting for the scan to finish result in the new file becoming visible in the My Cloud App?

Finally, if none of the above helped, your problem could still be a file permissions problem. Check the properties of the file at the source, before you copy it. Is the file hidden? Is the User “Everyone” allowed to “Read & execute” it, or at least “Read” it? (On my PC I can see that Everyone can “Read & execute” plus “Read” plus “Write” the sample video files, plus it has some Special Permissions. I canalso see the Unix User\root and Unix Group\root permissions.)

Sorry that was so long, but we werent’ getting anywhere, so I thought I needed to describe some stuff. Did any of that help?